8.5 kickstart "AppStream" error

Trying to install hosts through a kickstart setup using a local repo.

The .ks file has the following installation source and repo declarations

nfs --server=<file server> --dir=/var/lib/repo/8.5/BaseOS/x86_64/os
repo --name="BaseOS" --baseurl=nfs:<file server>:/var/lib/repo/8.5/BaseOS/x86_64/os
repo --name="AppStream" --baseurl=nfs:<filer server>:/var/lib/repo/8.5/AppStream/x86_64/os

Kickstart gets to the point of actually installing packages, then fails with

16:51:48,976 ERR payload.manager: PayloadError: Failed to download metadata for
repo 'AppStream': Cannot download repomd.xml: Cannot download repodata/repomd.xml: All mirrors were tried
16:51:48,978 DBG payload.manager: Updating payload thread state: ERROR

This kickstart infrastructure has been in place for awhile and has worked fine up through CentOS 7, so I’m pretty confident it’s not an NFS problem or some such. I’ve tried various combinations of repo declarations, and they all either fail to work at all or fail with the above error. Clearly it’s not finding the AppStream repo where it expects to find it, but I have no idea how to fix that.