9.1 Workstation GUI - After update: `startkde: symbol lookup error: /lib64/libKF5GuiAddons.so.5: undefined symbol: wl_proxy_marshal_flags`


I installed KDE via sudo dnf --enablerepo=epel,crb group -y install "KDE Plasma Workspaces" "base-x" - and it worked fine until yesterday. After a system update it crashed back to the GDM, and when using startx in a terminal user, or using startkde in a gui terminal, I get the error from the title:

startkde: symbol lookup error: /lib64/libKF5GuiAddons.so.5: undefined symbol: wl_proxy_marshal_flags

I’m not a linux pro, and while I found some info regarding that same error (namely someone in the openSUSE forums that had it years ago), I wasn’t able to use it to solve the issue.

I tried reverting the update via dnf history, but it said the packages were not available any more.

Any help is massively appreciated. I just can’t do well with gnome :smiling_face_with_tear:

1 Like

I have the same error when launching okular from gnome, both X11 and Wayland.