AL 8.6 warning: It seems your ruby installation is missing psych (for YAML output)

Not sure where I’m going wrong here. All packages seem installed, but I cannot get Ruby 3.2.2 installed (modern ruby-build).

/tmp/ruby-build.20230502170622.31398.BtFdIG/ruby-3.2.2/lib/yaml.rb:3: warning: It seems your ruby installation is missing psych (for YAML output).

[Tue May 02 17:09:18 user3@server_f ~] yum search psych
======================= Name Matched: psych =========================
rubygem-psych.x86_64 : A libyaml wrapper for Ruby
rubygem-psych.i686 : A libyaml wrapper for Ruby
[Tue May 02 17:09:35 user3@server_f ~] sudo yum install -y rubygem-psych
Last metadata expiration check: 2:56:52 ago on Tue 02 May 2023 02:12:55 PM EDT.
Package rubygem-psych-3.0.2-110.module_el8.6.0+3074+4b08f9d4.x86_64 is already installed.
Dependencies resolved.
Nothing to do.

This was performed earlier:
sudo dnf install -y epel-release

Anybody know what I have to do here? Cheers

The el8 has five streams of ruby: 2.5, 2.6, 2.7, 3.0, and 3.1. The 2.5 is the default and what you have installed. I’d guess that psych for 2.5 is “too far” from what 3.2 expects.

The first thing is that you could switch from the ruby:2.5 into ruby:3.1.
For switch, see: Chapter 6. Managing versions of Application Stream content Red Hat Enterprise Linux 8 | Red Hat Customer Portal

Then there is still the question, do you really need the 3.2? The general rule of Enterprise Linux is that if it provides something, then you do use that. The el8 provides Ruby 3.1.

I’m already running ruby 3.1.2p20. The updated ruby-build recognizes ruby 3.2.2, so I thought all dependencies would be up to date.

I will see if the ruby-build people have an option.