AL8.7 Network not working after each Update of NetworkManager

Hi guys,
I still got the problem that my network isn’t working after updating the NetworkManager packages via dnf. This happend everytime an Update for NetworkManager ist available and I installed it.
I can’t reach the server via Ethernet, I must use the IMPI Interface from Hardware Vendor to get conncted to the Console of the server to reboot the machine for getting a working networking again.
I tried several CLi command like:
nmcli networking off
nmcli networking on
systemctl stop NetworkManager
systemctl start NetworkManager
nmcli c down eno2; nmcli c up eno2

but nothing helps to bring up the connection.
The interface is listed with correct IP and also as connected (ip ro / nmcli d s) but the network port seems to be dead until a reboot.

any idea?
Best Regards,

Today same here.
Tried 2 times upgrading from Alma 8.8 to 9.2
Result no networkconnection anymore.
In my case no IP adress from DHCP.
Network port stated offline.
nmcli or mtui is saying no device.
Something messed up with dbus, ist nor started because of depending former error.
I also tried to add a second networkcard.
OS detects the new card but some port stated offline.
Have role back to a snapshot before upgrading.
8.8 is working fine.

After a long time fiddeling around i found ther reason why the upgrade failed.

The dbus-daemon was not started an disabled by default.
After enable it and start, the network drivers came upan got an ip as configured.

After a final reboot everything works as expected.
The strange thing is why the dbus-daemon is disabled by default.

But anyway

1 Like