Alma Linux install


Got a newbe install question here…

I am trying to install Alma Linux on a Dell desktop PC. The PC has windows 11 running.

I have created a bootable usb stick with Rufus.

The installation starts up just fine.

When I am going into the Installation Desitination I do not get the hard disk of the pc as an option. The only option I have it to install linux on the USB stick I am have the install files on.

Do you konw what causes this?

Best regards

A disk is allocated to blocks called “partitions”. Each partition contains (usually) a “filesystem”. Those have files.

The Windows installation does allocate entire disk to partitions by default (and so does Alma’s installer). No unallocated disk → no space.

Windows does allow resize of its partitions. It should be possible to shrink Windows “drive” (as long as files in it still do fit). Disk Management shows the options and will shrink both filesystem and partition. That leaves some of the disk unallocated.

PS. The default filesystem in Alma is XFS and XFS does not have the shrink option.

Thanks for the answer.

I have tried to shrink the windows partition. So no about 100 gig of the disk is not allocated to a partition. Still I only get the USB stick as a installation destination.

Best regards Vidar

You could go through this shrinking process but the windows disk encryption could be the next problem.

I`d recommend to buy/install a separate SSD for Linux and to have two completely separate systems on your hardware. This simplifies the process a lot because it comes down to a Linux installations.

Will the Almalinux installer get an upgrade to fix this sometime in the future is it planned at this point in time?

We have not established why your run doesn’t not see the expected destinations.
Hence, we do not know yet whether things go “by design” or if there is a bug.

As long as there is not enough information about alleged bug, nobody can report it to anyone who could actually do something about it.
(These fora are primarily peer support, although AlmaLinux maintainers do peek here.)

I think the install program should be reviewed and tested, I had the following issues on my notebook:

  1. The encryption key was not recognized - it worked only after the 3rd complete installation
    2: It was impossible to install AlmaLinux 9 using the installation files from the USB stick, the installation triggered always a time consuming web download of the installation files.