Almalinux 9.2 - print to network printer

Hello everybody,
Apart from using Almalinux 9.2 on as my server os (just to run my local Nextcloud) I‘m trying to use Almalinux as a desktop os.
I installed the desktop environment without choosing any options. Everything works fine, but I can‘t access my remote printer which is connected to my fritz box…
My configuration is as follows:
I installed firewall-config and activated dhcpv6-client, ipp-client, mdns, opened the ports 631 - tcp and 631 - udp everything in the public zone. Up to Almalinux 8 that did the trick.
The printer dialog sees my (canon MG7100) printer, but says it could not install the driver. I saw a SELINUX-message, so I deactivated SELINUX. Still the same. I choose the driver manually, to the same result. I can send a page to the printer but nothing will happen.
Now I‘m completely stuck - can anybody help?

Hello again,

I got the printer up and running after installing turboprint. I’m not sure what exactly that means?

Can anybody explain?

Thanks again