AlmaLinux 9 goes in maintenance mode after cloning (VirtualBox)

On my desktop environment, I have created a virtual machine which is used as base installation on VirtualBox.

The base installation is then used to create new virtual machines as required through the VirtualBox clone function. It has worked for CentOS 6, CentOS 7 and AlmaLinux 8 (RedHat equivalent as well).

For some reason, it does not work for AlmaLinux 9. It is very handy to be able to quickly clone a VM and have just work instead of having to jump into rescue mode and perform fixes each time.

SE Linux has been disabled, UEFI is enabled and secure boot is disabled. It seems to be having issues with finding the LVM volumes.

What has changed in AlmaLinux 9 that I no longer am able to clone the virtual machine?

When in maintenance mode, when I tried to run pvdisplay, vgdisplay or lvdisplay, I get a message as below:

 Devices file sys_wwid eui.312757f5a371ce78000c296dd0907eb0 PVID TnGzeNPVwiUODoKU8irccjggtPi4eJcQ last seen on /dev/sda3 not found.

LVM’s Devices file is located here: /etc/lvm/devices/system.devices. Renaming it to .bak is a work around. LVM will fall back to using device names if the specific HW info is unavailable. Refer to this post.

Problem seems to be isolated to AlmaLinux 9.2. Previous versions does not have this problem.

it works fine using qemu-kvm, so i’d suspect virtualbox, which version is it?

Here is the best explanation and action plan for this problem