Almalinux-deploy on systems with unresolved rpm issues

New to AlmaLinux…

What is the recommended way to run almalinux-deploy to update old Centos 8 systems when there are minor RPM dependency issues on the system. By way of example for a “minor RPM dependency issue”, let’s say an installed RPM requires “/usr/bin/python” but of course in Centos 8 there is no “python” - there is only “python2” and “python3”. So if the problematic RPM was installed with “–nodeps” to get around this (it does not really use python), and everything works fine… but when running I get this error…

Problem: cannot install the best update candidate for package aerospike-server-community-

  • nothing provides /usr/bin/python needed by aerospike-server-community-
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

After getting the above error, if I just run a normal dnf update, it seems to update the system just fine. From what I can tell, the upgrade to AlmaLinux release 8.8 (Sapphire Caracal) works just fine running a dnf update after getting the above error.

Is there a “right” way to do it?

I tried sudo alternatives --set python /usr/bin/python3 made sure exclude=aerospike* is in dnf.conf but still get that error.