"At least 48MB more space needed on the / filesystem" running leapp upgrade

Hi,

I’m trying to upgrade from Rocky Linux 8.9 to Rocky Linux 9 using the leapp upgrade. At some point the process stops and shows the following error:

Error Summary
-------------
Disk Requirements:
   At least 48MB more space needed on the / filesystem.

We had a similar problem in the past when upgrading from CentOS 7 to Rocky Linux 8, and learnt that this was due to the OVL size rather than the space available in the filesystem, so got this fixed by increasing the size assigned to OVL (i.e. export LEAPP_OVL_SIZE=5000). Although this worked for the previous migration, increasing the OVL size does not seem to fix the issue for this migration.

This is the output when I run ‘df -h’:

Filesystem      Size  Used Avail Use% Mounted on
devtmpfs         16G     0   16G   0% /dev
tmpfs            16G     0   16G   0% /dev/shm
tmpfs            16G  488K   16G   1% /run
tmpfs            16G     0   16G   0% /sys/fs/cgroup
/dev/nvme0n1p1  100G   41G   60G  41% /
/dev/nvme2n1    5.0G  666M  4.4G  14% /var/lib/docker
tmpfs           3.1G     0  3.1G   0% /run/user/1003

Any ideas of what else I could try?

Thanks,
Tedi

I also ran into this. For me it was “an overlay issue” A lot more digging got me this:

Try setting the following in your shell before running the leapp commands.
export LEAPP_OVL_SIZE=4096

You can do this manually or put it in your root .bash_profile.

It was indeed my fault since I missed the ‘preserve-env’ prefix when running the upgrade command. For the benefit of others having the same problem, this should work:

sudo --preserve-env leapp upgrade