AutoFs in Alma 9.2

Hello all,

I’m running into a final snag on autofs. It appears that the RHEL9 packages resolved it, but since installing Alma, they aren’t resolving and trying to figure it out.

When I run make, this is the output I am getting, which appears to be due to the ld linker being unable to find the master_get_logopt function. Thank you

/usr/bin/ld: …/lib/autofs.a(cache.o): in function cache_update': cache.c:(.text+0x1233): undefined reference to master_get_logopt’
/usr/bin/ld: …/lib/autofs.a(cache.o): in function cache_update_offset': cache.c:(.text+0x13f0): undefined reference to master_get_logopt’
/usr/bin/ld: …/lib/autofs.a(cache.o): in function cache_delete_offset_list': cache.c:(.text+0x1b98): undefined reference to master_get_logopt’
collect2: error: ld returned 1 exit status
make[1]: *** [Makefile:33: automount] Error 1
make[1]: Leaving directory ‘/usr/src/autofs-5.0.7/daemon’
make: *** [Makefile:14: daemon] Error 2

why are you compiling autofs instead of just running sudo dnf -y install autofs ?

1 Like

Because we have custom embedded code in autofs 5.0.7.
The part that is compiling with errors is NOT our embedded code.
Do you have any input on the error we are getting?

ok, I used what you asked, though, and installed the latest autofs, which installed all the packages normally used, then removed the latest rpm, and compiled. now it works. Thanks!

1 Like

“undefined reference” is a linker error; all objects are not present for the linker. You probably know better, who supposedly provides the implementation of ‘master_get_logopt’.

Overall, I’d try to rebuild the autofs from its (Alma) src.rpm. If that works, then add your patch to that process. (I have no idea how to actually do that, but that seems the logical approach.)

[Edit] Too slow …