Block/unblock the maximum files per directories?


CONTEXT : Millions of files in 1 directory / EXT4 formatted / tons of inodes available…

PROBLEM : when a directory reach (example 1 million files) I get “no space left” error when I wan to add new files in this directory only… adding files to other directories = ok.

WHAT I READ (somewhere ?) : …something about that it could manually changed to contain some users from creating a large number of files and consuming all the inodes.

QUESTION : How to “manually” change this setting ?


The ext4 is not supposed to have a limit on files/directory.

You might have seen “quota”. An ext4 volume can have user and group quotas that limit space and number of files for user / group on that volume.

(post deleted by author)

Thanks for pointing to quotas…

I had the feeling it was something, but didn’t knew the right term or right thing to look for.

I use WHM, and followed steps to disable quotas…

also in fstab I added noquota option

/dev/drive… /mointpoint ext4 defaults,noquota,nofail,discard 0 0