Cannot boot 9.3 install USB

Howdy,

I am trying to install a fresh version of AlmaLinux v9.3 Full Image to replace centOS Stream 8. I created USB boot disk using the dd command and have checked that the install USB sha256 matches that of the ISO and of the hash from the download page. I can boot the image, but when I attempt to install, it hangs. Any help would be appreciated.

System:
Mobo - Asrock X570M Pro 4
BIOS - 5.60
CPU - Ryzen 5600X
Microcode - A20F10/A20102B

SSD - Saberant Rocket NVMe 4.0

AlmaLinux
v9.3
DVD ISO
SHA-256 : 4a8c4ed4b79edd0977d7f88be7c07e12c4b748671a7786eb636c6700e58068d5

The dd utility doesn’t do any write verification, so it’s possible you have a corrupt write to the USB. I suggest verifying the iso and then writing it with livecd-iso-to-disk (from the livecd-tools package) or the Fedora Media Writer instead.

I thought the same thing, but I ran SHA256 on the USB device and it matched and I am able to boot the USB on a Dell OptiPlex 7010 machine with a 3rd gen i5 CPU. Ran the verify/install option and the USB passed the verification and the install GUI loaded after on the Dell machine.

Not sure what the issue is on the AMD machine…

I very much doubt it’d the AMD proc. I’ve ran AlmaLinux 8 and 9 on a number of AMD boxes in my dayjob without issue. I’m curious if the 9.2 iso works? If so, you could install that, then dnf updateand you’ll be caught up.

Was going to try 9.2 next. Am currently running CentOS Stream 8 and that installed no issue back in the day. Am starting to wonder if a MoBo/BIOS thing with RHEL 9…

Will update after trying 9.2

1 Like

You could using elevate to go from CentOS Stream 8 to AlmaLinux 9 as well.

So, got 9.2 installed. Had to do the text install option under “Troubleshooting” as the GUI failed to launch. I then used VNC to do install from another system. I selected the “Server with GUI” option and the install completed. However, upon reboot, I was present with a command prompt to login, not a GUI. Not a huge deal as I do everything command line anyway. Then, I ran dnf update, which put the 9.3 version/kernel on the machine. Rebooted and…it hangs at

Booting 'AlmaLinux (5.14.0-362.18.1.el9_3.x86_64) 9.3 (Shamrock Pampas Cat)'

v9.3 really does not like this CPU/MoBo combo…

It seems like there may be an issue with using an NVMe as a boot drive in the 9.3 release


1 Like

I’m curious about the Ubuntu references in there?

I noticed that as well. I made the USB on an ubuntu system, but there is no ubuntu disk connected. There is a second NVMe in the system with centOS Stream 8 on it. On a root into 9.2 i noticed that the machine named itself ‘unifi’ so i am assuming that reference is just a weird network domain name thing from mu router. I can check the boot args for 9.2 tomorrow.

1 Like

I’ve found it impossible to boot from an NVMe into 9.3 using 5.14.0-362.18.1.el9_3.x86_64. I raised this on talk and Andrew Lukoshko asked if I had an NVMe but I’ve heard nothing since then. I booted using the old kernel (5.14.0-362.13.1.el9_3.x86_64) and then removed the new one (and of course the entry in /boot/loader/entries). Seems to be working finr in this “cut back” configuration.

Booting Alma that is installed on NVMe:

[Alma9]# lsblk -i
NAME         MAJ:MIN RM   SIZE RO TYPE MOUNTPOINTS
nvme0n1      259:0    0 476.9G  0 disk 
|-nvme0n1p1  259:1    0   200M  0 part /boot/efi
|-nvme0n1p2  259:2    0     1G  0 part 
|-nvme0n1p3  259:3    0    20G  0 part 
|-nvme0n1p4  259:4    0    16G  0 part [SWAP]
|-nvme0n1p5  259:5    0    40G  0 part /local
|-nvme0n1p6  259:6    0     1G  0 part /boot
|-nvme0n1p7  259:7    0    24G  0 part /

[Alma9]# uname -r
5.14.0-362.18.1.el9_3.x86_64

works for me (multiple systems), but that does not prove that it would work on all setups, nor explain issues with install media on USB.


rd.lvm.lv=almalinux_ubuntu/root tells that kernel should activate on boot LVM2 LV “root” from VG “almalinux_ubuntu”. The AlmaLinux installer does name VG (if LVM2 is used) by default almalinux_$(hostname), so the installer has most likely received hostname “ubuntu” (typically from DHCP). For example, if one has configured the DHCP to hand out specific IP address and name for the MAC of machine.

The “unifi” I’ve seen as product name of Ubiquiti Networks.

# lsblk -i
NAME                MAJ:MIN RM   SIZE RO TYPE  MOUNTPOINTS
...
nvme0n1             259:0    0 465.8G  0 disk  
|-nvme0n1p1         259:1    0     1G  0 part  /boot/efi
|-nvme0n1p2         259:2    0    10G  0 part  /boot
`-nvme0n1p3         259:3    0 331.4G  0 part  
  `-almalinux-root  253:0    0   300G  0 lvm   /

Perhaps 18 + LVM?

Exciting. I’ve never been that wild with LVM (and don’t have that many “standard” GPT partitions either.)

Anyone have any luck getting this working?