Can't connect to the NAS storage

Hello. I normally in fedora open the window manager and select the other locations, then by it self it shows my storage. But I cant see it in alma linux.

Please advice, thanks.

Just a picture to show what I mean.

sorry, but your question is still not clear to me. The space above your “Should show up here” shows the icon for Computer.

Have you double-clicked that? Or what is it you are looking for very specifically?

@warron.french If it’s NAS then it won’t show up as being attached to “On This Computer”, because it isn’t!
@katana85 I’m sorry I can’t help, but one thought has occurred to me: assuming it has a known network name or IP address, can you ping it? If so you eliminate network issues and then can look at ID settings. Just a passing thought.

@MartinR , thanks, that puts the question into context now.

@katana85 , have you confirmed that the NFS mounts are showing up when you use:

df -h

If not, then first make the mounts manually and confirm they work with the ‘df’ command; then make the appropriate adjustments to your /etc/fstab.

Something else to check: are there any firewall issues? Whilst on the topic, how does SELinux play with this?


I disabled the SElinux and it didn’t work.

I disabled the firewall using ‘sudo systemctl disable firewalld’. Then I restarted the system for it take effect and it worked.

Even though disabling the firewall is not a good solution, it did fix the problem and I understood where the issue is coming from.

Right know it is about configuring the firewall so I can enable it without any issues.

Please advice me. And thank you.

@katana85 can you please provide the logs from the firewall while its on and you try to access it?

Please guide me to an article to learn about this.

@katana85 this website will help you.