Cant install amd graphics driver

Hello. I am trying to install the AMD graphics driver for my laptop. I got the drivers file from AMD. But:

[ahmed@alma8 amdgpu-pro-20.45-1188099-rhel-8.2]$ ./amdgpu-pro-install
Unsupported RPM-based OS: /etc/os-release ID ‘almalinux’

I opened the amdgpu-pro-install in a gedit and it seems that it supports some distros like RHEL and centos.


Can I modify this and add alma? I am willing to experiment.

Please advice me.


If you’d like to experiment and you are aware this may break things, you can try adding almalinux after centos so rhel|centos|almalinux and see if that does it for you.

That being said, there could be other places where the OS is parsed out that may cause this to fail, break or do something else equally nasty. So just keep that in mind. :wink:

Well. I am happy to report that the installation worked successfully.

But the laptop has two graphics (Intel and AMD) and it seems in the options → Details. That it only detects the Intel graphics.

Should the AMD graphics works automatically or I need to select it? And I can feel is system graphics getting better.

@jack , what is the default video driver on an ALMALinux OS? Is it also nouveau? I am at work and no where near an ALMALinux machine.

If that is the case you need to create a blacklist of the nouveau driver. Once you blacklist the native video driver you will have a functioning AMD GPU, but not necessarily a functioning Intel GPU.

I never worked with two different brands/competing GPUs in the same chassis, so I am not certain if the nouveau driver works with such a configuration. That could be your issue, maybe not.

To determine if your present video driver is “nouveau” you might be able to execute the following:
lsmod | egrep nouveau

That has worked for me on both CentOS and RedHat in the past, but not presently on my current physical machine (Go figure).