Cockpit isn't available until I log in at the physical server


I installed cockpit on my AlmaLinux installation. That installation is “server with GUI”.

I can’t get cockpit to listen to a remote login until I do log in to a user at the server itself.

Any help would be highly appreciated.


Did you enable it at boot?

systemctl enable --now cockpit

local firewall may block. try something like

# firewall-cmd --add-service cockpit
# firewall-cmd --add-service cockpit --permanent

Does the “log in” automatically start the listening?

Is the network up by default?

The “server with GUI” installs services like Wayland/X11, gdm, and Gnome that are entirely unrelated to cockpit, which is http-based service.