Crash during the installation of AlmaLinux 8.x/9.x on Windows11 with QEMU 6.x and/or 7.x

we need the help for an project in which we want to bring an Linux into a
Windows environment by using QEMU native.

What we have done:
we have tried to install AlmaLinux 8.x/9.x on an Windows11 with QEMU 6.x/7.x.
In every case we get a panic information (see HC).


  1. ACER Nitro 5,AMD 5800H, 64 GB RAM, 2 TB HDD
  2. ASUS, AMD 5800X, 128 GB, 9 TB HDD

In both system Windows 11. In 1) Win11 Home in 2) Win11 PRO.

The following command we use:
& ‘C:\Program Files\qemu\qemu-system-x86_64w.exe’ -m 4096 -machine pc-q35-2.12 -device AC97 -smp 2 -vga std -usbdevice tablet -hda C:\VM\nextcloud.img -cdrom C:\VM\AlmaLinux-9-latest-x86_64-dvd.iso

Hint: Onto the same systems if use VirtualBox it is possible to install the AlmaLinix system.

Hint2: If we try to install (for an example) Fedora with QEMU 6.x/7.x into the same systems it works without any issues.

Thanks for any help

pc-q35-2.12 is hideously old and almost definitely won’t support any recent RHEL variants, you could just use q35 which should be an alias to whatever the latest is, you can find your supported machine types via:

$ qemu-system-x86_64 -machine ? | grep q35
q35                  Standard PC (Q35 + ICH9, 2009) (alias of pc-q35-7.2)
pc-q35-7.2           Standard PC (Q35 + ICH9, 2009)
pc-q35-7.1           Standard PC (Q35 + ICH9, 2009)
...huge list...
pc-q35-2.10          Standard PC (Q35 + ICH9, 2009)

Thanks a lot sej7278.

I have changed the commandline to the following:
PS C:> & ‘C:\Program Files\qemu\qemu-system-x86_64w.exe’ -m 4096 -machine q35 -device AC97 -smp 2 -vga std -usbdevice tablet -hda C:\VM\nextcloud.Almalinux.9.1.img -cdrom C:\VM\AlmaLinux-9-latest-x86_64-dvd.iso

Unfortunately the same result (please see the new HC).

Best regards


oh this is probably the x86-64-v2 thing, you need to pass “-cpu host” to fix it (assuming your host cpu is new enough):

if AL8 didn’t work, then you probably need to disable hyper-v in windows or something.

1 Like

Good morning sej7278,

Great ! This hint solve the problem. We use the AMD EPYC and all went ok.
We use AlmaLinux 9.1 and it looks fine.

Thanks a lot and have a nice weekend

Best regards


1 Like