Cups-pdf installation

how to install cups-pdf on AlmaLinux8.5 ?
dnf search cups-pdf does not show any package.

Are you really sure you want to do this? The home page, here, seems to be nearly 7 years out of date. If you need to print a PDF, then just use $ lp <file>.pdf.

yes pdf printing “just works” these days, you haven’t needed cups-pdf for years

In my case i need this user pdfspooler is a part of package cups-pdf, there is one script which has to be own and managed by pdfspooler.
Is there any way out to install it on AlmaLinux 8.5 ?
I have checked CUPS-PDF - Download
but there is nothing for Centos, means AlmaLinux
and have tried

yum update
yum -y install cups gcc gcc-c++ cups-devel tar wget
tar -xvf cups-pdf_3.0.1.tar.gz
cd cups-pdf-3.0.1/src/
gcc -O9 -s cups-pdf.c -o cups-pdf -lcups
chmod 700 cups-pdf
cp -p cups-pdf /usr/lib/cups/backend/
cd …/extra
cp cups-pdf.conf /etc/cups/
cp CUPS-PDF_opt.ppd /usr/share/cups/model/
sed -i “s/Allow @LOCAL/Allow all/g” /etc/cups/cupsd.conf
systemctl restart cups
systemctl enable cups

But still there is no such user pdfspooler.

Hi @Malik,
Actually yes, you can install cups-pdf but you have to compile the .rpm yourself starting from the source rpm package.
Download the .src.rpm for FC34 from here (click on cups-pdf-3.0.1-13.fc34.src.rpm link) then follow the rpm compiling example I gave here.
I tried now the rpmbuild on AlmaLinux 8.5 and the rpm is compiled OK; though I didn’t installed it, because… (me too) I didn’t needed it for years… Hope it still works as expected.

Good luck !