Disable Automatic Updates

New to this, so don’t understand it:
I created a VM with AlmaLinux 9.3. It is MANDATORY that it remain at 9.3 in order to do keep testing for applications on that version.
Imagine my shock when I walked away and came back, and it was in the middle of updating to 9.4! When it was done, it shut down – didn’t even reboot.
It’s critical that this is disabled. And no, I’m not using cockpit like others have commented. What am I missing?
This behavior is too much like Microsoft forcing updates and shutdowns when you have applications and programs running. This pretty much goes against all things Unix!
Thanks for any suggestions.

I think never mind on this one… Just noticed a check box while shutting down about “Install pending software updates.” Never noticed it before because I usually just click fast through everything.
So now the question becomes: How can I set this extremely annoying “feature” so that this option is ALWAYS UN-checked?

AFAIK, that “convenience” is by PackageKit.
See dnf list PackageKit\*