Disabling hyperthreading

I’m trying to disable hyperthreading in an AMD (EPYC 73F3) machine running on AlmaLinux 8.8 (Sapphire Caracal). I made “SMT Control” disabled in BIOS. However, and after rebooting my system, it seems still in hyperthreading mode, returning
Core Count: 16
Thread Count: 32
when I use command below.
#dmidecode -t processor | grep Count
Referring to Simultaneous Multithreading in Red Hat Enterprise Linux - Red Hat Customer Portal, I also tried
#grubby --args=nosmt --update-kernel=DEFAULT
#grubby --args=noht --update-kernel=DEFAULT
and rebooted the system but got no change. The command
#cat /sys/devices/system/cpu/smt/control
retured “notsupported”.
Does anyone have any experience trying to accomplish this goal?
Thank you!

I did do it 2 times, once by editing grub.cfg in boot directlyand secondly in runtime. While not recommended at runtime, you can disable hyperthreading using:

echo off | sudo tee /sys/devices/system/cpu/smt/control

Thank you! I will try it.