Distorted audio on Lenovo Thinkpad T16 Gen 2


The audio on my thinkpad works fine after each startup, but at random point in time gets terribly distorted without any action on my side. This happens e. g. in every virtual meeting - regardless of the software used. At some point (sometimes an hour in, sometimes 10 minutes) the audio switches to an almost unintelligible distorted sound mixture - both in speakers and in headphones. I’ve not had any luck debugging this, so any help will be highly welcome!

A bit more info would be helpful here:

  • is this T16g2 an AMD or Intel model?
  • are you running the latest BIOS on the T16g2?
  • what version of AlmaLinux are you running?
  • have you checked to see if there are any errors reported by systemd around the time the audio starts to degrade?

If the T16g2 shares some of the same components with the T14g2 then there’s a possibility the sound issues could be related to needing some specific ALSA firmware, at least on Intel models.

Thanks for your response!

  • It’s an Intel model (i7-1365U)
  • I’m running what appears to be the latest bios according to the Lenovo support website (1.39)
  • I’m running AlmaLinux 9.3
  • I will check for errors in my next call!

Do you please have any pointer to the T14 issue you’re mentioning? Many thanks!

Hi, kovy,

Cool, thanks for the extra details :slight_smile:

OK, so it definitely looks like you’re on the latest BIOS for that model, and I would tend to think the newer 5.x kernel in AL9 might work better than the 4.x one in AL8…

This Arch Linux Wiki article on the support status of the ThinkPad T14/T14s Intel Gen 2 includes a note that additional ALSA firmware (not included even in a much newer kernel) is needed for the internal sound card to work.

I actually find this a bit strange, as I’ve run Arch Linux on a large number of both Dell and Lenovo laptops (but nothing past 9th gen Intel), and have yet to run into this requirement for additional ALSA firmware… but could be worth looking into this, just in case.

Once you start hearing the audio misbehaving, try opening a terminal and see what this might show?

$ journactl -xe 

Alternatively, I sometimes find it helpful to keep a terminal window open to see a live feed of potential error messages when I’m troubleshooting a particular issue. You could try running this command (requires root or sudo) to do this:

# dmesg -w -H 

Hope some of this helps… good luck!

1 Like

This had been happening for me for a while until I realized that I had auto-adjust enabled on Zoom and it was the culprit. Disabling the auto-adjust feature in Zoom fixed it for me (on a different but similar generation ThinkPad model).

Thanks a lot!

I the meantime, I’ve tried reinstalling pulseaudio, which was recommended by the local IT department - I’m yet to see if that made any difference. I’m having some meetings today, so I’ll be back with the journalctl output if the audio gets distorted again!

Hey, I can only see microphone auto-adjust, is that what you mean? Cheers!