Dokuwiki under Alma

Has anyone managed to get DokuWiki running under Alma? I have it running happily on a CentOS 8 VM but both in an Alma VM and now on the Alma bare metal it simply shows me a blank page. The installation script runs, but then I get nothing.

1 Like

@MartinR Can you provide more information? How did you install? Did you get to the installer page? Are you running SELinux on enforcing and if so, did you create the proper policies?

Also, do you have any logs from either your webserver or dokuwiki itself?

I downloaded the tarball from DW: dokuwiki-2cf7f84250110f149f7c037c71c76330.tgz which contains 2018-04-22c "Greebo".

Running as root:

  1. I expanded the tarball (tar -xvz -f) to build a dokuwiki tree in my software store.
  2. I moved the DW tree into /var/www/html
  3. I ensured suitable ownership (chown -R apache:apache)

Running as apache:

Running as myself using Firefox (78.10.0esr 64-bit):

  1. I ran http://localhost/dokuwiki/install.php, filled in the form and pressed “save”.
  2. Got the message " The configuration was finished successfully. You may delete the install.php file now. Continue to your new DokuWiki."
  3. Clicked on the link and there was nothing but a blank page.

The page source (from Firefox) was:

<!DOCTYPE html>
<html lang="en" dir="ltr" class="no-js">
    <meta charset="utf-8" />
    <title>wiki:welcome [Lifeboat]</title>

For information:

# getenforce

I have repeated the user steps (after deleting /var/www/html/dokuwiki/conf/{local,users,auth,acl.auth}.php so that the installer will run, exactly the same result.

The httpd access log is:

::1 - - [11/May/2021:08:36:06 +0100] "GET /dokuwiki/install.php HTTP/1.1" 200 8125 "-" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"
::1 - - [11/May/2021:08:36:06 +0100] "GET /dokuwiki/lib/tpl/dokuwiki/images/button-dw.png HTTP/1.1" 304 - "http://localhost/dokuwiki/install.php" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"
::1 - - [11/May/2021:08:36:06 +0100] "GET /dokuwiki/lib/tpl/dokuwiki/images/button-php.gif HTTP/1.1" 304 - "http://localhost/dokuwiki/install.php" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"
::1 - - [11/May/2021:08:36:06 +0100] "GET /dokuwiki/data/dont-panic-if-you-see-this-in-your-logs-it-means-your-directory-permissions-are-correct.png HTTP/1.1" 403 199 "http://localhost/dokuwiki/install.php" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"
::1 - - [11/May/2021:08:36:06 +0100] "GET /dokuwiki/lib/exe/fetch.php?media=wiki:dokuwiki-128.png HTTP/1.1" 200 27895 "http://localhost/dokuwiki/install.php" "Mozilla/5.0 (X11; Linux x86_64; rv:78.0) Gecko/20100101 Firefox/78.0"

The error log shows:

[Tue May 11 08:36:44.385736 2021] [access_compat:error] [pid 2142:tid 140688723994368] [client ::1:37268] AH01797: client denied by server configuration: /var/www/html/dokuwiki/data/dont-panic-if-you-see-this-in-your-logs-it-means-your-directory-permissions-are-correct.png, referer: http://localhost/dokuwiki/install.php

There are no relevant messages in /var/log/secure (grep http secure).

There are several screenfulls of messages, all SELinux moaning. Filtering by using grep http messages | grep 08:3 | grep -v "you must tell SELinux" leaves two, both of which are SELinux preventing write access. However, as noted above, SELinux is in permissive mode.

Sorry if this is a bit long-winded. Thanks, Martin

@jack I’ve also been working with the folks over on the Dokuwiki site, specifically Andi, and he gave me the pointer I needed. The problem was that php-json hadn’t been installed.

There were a few other hiccoughs along the way, see the discussion there if you’re interested. I suspect that on previous incarnations I’d been running Ganglia which uses json quite a lot, whereas on the Alma machines I’m not running it.