Error starting VM with almalinux 8.9

I have 1 machine with almalinux 8.9 on proxmox 8.1, when I reboot the machine it will hang showing the below message on conole

probing edd (edd=off to disable) … ok

i tried edd=off on the grub but it does not helo

How can I resolve this issue?error posted in proxmox forum

Thanks for including the specific version of Alma Linux being used (8.9).

  • What are the details of the base host’s hardware (Make, Model, Generation, BIOS version, etc.)?

  • Have you tried creating a separate VM of a similar configuration (same vHD, vRAM, vCPU core count and flag settings, etc.) on this same Proxmox host, but using a different linux distro (Fedora, Ubuntu, etc.), and seen different results?

I’ve only seen this once or twice before–not even virtualised, but physical–maybe with CentOS 7? Trying to remember, but it was quite some time ago. In both cases they were really, really old computers, and we ended up just having to replace them.

That said, since you’re encountering this on a Proxmox host, this might be something which can be resolved by tweaking the CPU masking/settings presented to the VM via Proxmox, perhaps… ?

Curious to learn more about the hardware details in use here…

Thank you for your reply
The host server is Dell EMC PowerEdge R6515 provided by dell with the below specifications

CPU: 64 x AMD EPYC 7502P 32-Core Processor (1 Socket)
machine specification is attached

do you think I should move it to intel processor server (so the problem expected AMD processor)

please note that i did some research and I would expect virtio driver issue.
what is your advise?

Hi, maherkhalil,

I’ve not installed Proxmox on an EPYC system yet, but had no issues getting Ubuntu 20.04 stable with a 64-core R6525 a few years ago. I don’t think you necessarily need to move to a server using an Intel CPU to get this working.

Was this VM originally created on this same Proxmox host, or was it moved/migrated from a different Proxmox server, possibly using a different processor? Just curious.

So here’s one fairly obscure trick you can try on the VM hanging at the “probing edd” text:

  1. Open the VM console and start it (or reboot it if it’s already stuck)
  2. As the VM just starts to boot, and you see the GRUB boot menu, hit the “E” key, which will allow you to modify the boot parameters of the existing kernel.
  3. Use the down arrow key to move the cursor down to the line beginning with “linux” (which most likely also ends with rhgb quiet )
  4. Hit the End key to move the cursor to the end of that line
  5. Use Backspace to remove the words rhgb and/or quiet, if present, then add console=hvc0
  6. Hit ctrl+x to boot with this new, temporary setting

Note that this modification makes no permanent changes, and is only temporary. Also, if you happen to mistype something, or place it on the wrong line and it fails to boot at all, simply reboot the VM and try again, no worries!

This kernel option usually helps with console messages on systems utilizing the Xen hypervisor, but I’ve heard it has helped boot some problematic systems which get stuck at that “probing edd” message…

Hope this helps.
Good luck!


Thank you for your answer.
I found the issues because of using hotplug for memory and CPU.
CPU and RAM usage were very high.
so, I disabled these features and the VM reboots normally.
Thank you very much