Help installing smokeping via yum - AlmaLinux 8.6 minimal installation

I need some assistance installing smokeping via yum. Simple as it should be, it doesen’t work. When I try ‘yum install smokeping’ the following error occurs:
Problem: conflicting requests

  • nothing provides perl(Path::Tiny) needed by smokeping-2.8.2-1.el8.noarch
    (try to add ‘–skip-broken’ to skip uninstallable packages or ‘–nobest’ to use not only best candidate packages)

I’ve tried with both ‘–skip-broken’ and ‘–nobest’ without any luck. I think the issue is related to ‘cpan’, and I’ve tried manually installing ‘Path::Tiny’ in ‘cpan’ without any luck either.

If anyone have any ideas or know a way to fix this issue, it would be much appreciated.

Is in ‘powertools’ repo (which is disabled by default):

dnf --enablerepo=powertools provides 'perl(Path::Tiny)'
AlmaLinux 8 - PowerTools                                                          3.2 MB/s | 3.0 MB     00:00    
Last metadata expiration check: 0:00:01 ago on Thu 02 Feb 2023 04:03:08 PM EET.
perl-Path-Tiny-0.104-5.el8.noarch : File path utility
Repo        : powertools
Matched from:
Provide    : perl(Path::Tiny) = 0.104
1 Like

Thank you for your quick response. Enabling powertools and running an update fixed the issue. Thank you very much!