I can't get my network to connect!

I’m having to upload screenshots as i have to connect to the server via the iLO, no matter what i do i can’t get eno3/4 to pick up the ipv4 setup from the ifcfg-* files any ideas?

Screenshot 2021-07-28 151841

Screenshot 2021-07-28 151718

can you try this and see if it works? go into nmtui and then de-activate and re-activate the interface and see if it will pull down an IP?

I tried that (similar) using link ip interface up/down as nmtui isn’t installed

Hmm, It seems like eno0 has only RX traffic and eno4 has only TX traffic?

Also, would you mind grabbing the output from ethtool on both those interfaces and pasting it here (or a screenshot of it)?

“nmtui isn’t installed”

NetworkManager is the default connection management system.
The ‘nmtui’ is in separate package: NetworkManager-tui.
The ‘nmcli’ is in the base package: NetworkManager.

So yes, nmtui is more optional.

My routine check would first see whether NM is running:
$ sudo systemctl status NetworkManager.service

If that says yes, then query with nmcli and ip:

$ nmcli
$ nmcli d s
$ nmcli c s
$ ip ro

When i run that command it just says;
“Unit NetworkManager.service could not be found.”

I installed this using the minimum install do you think it bypassed network manager?


The repositories define groups:

# dnf -q group list
Available Environment Groups:
   Server with GUI
   Minimal Install
   Custom Operating System
   Virtualization Host
Installed Environment Groups:
Installed Groups:

The Environment Groups are groups of groups:

# dnf group info -q "Minimal Install"
Environment Group: Minimal Install
 Description: Basic functionality.
 Mandatory Groups:
 Optional Groups:
   Guest Agents

The “minimum install” includes only one group: Core (unless the installer does not use the “Minimum Install” group).

# dnf group info -q Core

Group: Core
 Description: Smallest possible installation
 Mandatory Packages:
 Default Packages:
 Optional Packages:

Since the NetworkManager is not flagged mandatory, then it is probably excluded from minimum?

Odd, the ethtool is in group Standard and you have it.

Anyway, if you have no service that would configure your network collections, then nothing will read your config files.

You have to get link up manually. Use the ip; the ifconfig was intended to be replaced by ip two decades ago.

That’s what i’ve been trying to do, so i can only conclude that the config of the file is wrong theneno3config

This is the config for eno3

Who reads your file? Nobody.

Manually, non-persistent:

ip link set eno3 up
ip addr add dev eno3
ip route add default via

The dns servers you need to edit to /etc/resolv.conf

Great that has an internet connection! So install networkmanager now and configure the other nic and it using networkmanager?

Yes, I would install NetworkManager and then configure all connections with nmcli.

However, the configuration in the file looks more or less like a connection created by NetworkManager (probably written by the installer). You might get both connections up by just install and start the service.

@jack Is the “no NM in minimal install” by design? I recall that CentOS 7 had “no net if you do minimal” many point updates ago (but these days it gets net).