Imapsync install issues

Trying to install imapsync from epel and we are getting this error:

[root@web8 ~]# yum install imapsync
Last metadata expiration check: 4:36:26 ago on Sun 25 Jul 2021 04:04:30 AM EDT.
Problem: conflicting requests

  • nothing provides perl(Readonly) needed by imapsync-1.977-2.el8.noarch
  • nothing provides perl(File::Copy::Recursive) needed by imapsync-1.977-2.el8.noarch
  • nothing provides perl(Test::Pod) needed by imapsync-1.977-2.el8.noarch

Looks like we have some missing dependencies? This does work on a straight Centos 8 server.

1 Like

Hi @GreenOT. Thanks for letting us know. Looking into this for you…

Just want to check in here, I tried again this morning and its still broken.

Any responses yet? I’m experiecing the same problem.

I’ve heard nothing and can confirm its still broken

Hello @maretha and @GreenOT. I just got wind of this. Will look into it now. Should have an update within 12 hours or so.

Missing packages are in PowerTools repo.
You can enable it during install by:
dnf install --enablerepo=powertools imapsync
Actually exactly the same behavior is on CentOS 8.

1 Like

The ‘imapsync’ is in EPEL.

Am I right that no package in BaseOS/AppStream depends on CodeReady/powertools content, but third-party repos (like EPEL) do build some packages that do depend?

Interesting, OK. When I tested on a Cent 8 server, it was Plesk so I guess it must have had the powertools already enabled.

Thank you.

That worked for me, with the same issue, as well! Thank you so much. :slight_smile: