Installation problem (8.3)

Trying to install on a DELL server (idrac9) using the boot.iso
I can configure IP/hostname/disk partitioning fine, but I get an “Error setting up base repository” I use

Try …/8/… rather than …/8.3/…

Same error. Is the ethernet card (Broadcom BCM57412 10G) supported?
It shows as connected, and getting an ip from my dhcp server. the idrac also shows a link but the error about setting up base repository persists!!!

From what you say it is unlikely to be the card. If the installations says it is connected and you are able to get an IP, then it must be working. Is there any reason that your connection to the internet could be problematic? You must put enough information in, but don’t add any extra stuff until youi’ve gotr it sorted out. See this thread for a similar problem.

I looked at that thread but mine is a file iso. I was able to install centos8.2 just fine and can get out on the Internet so the ethernet card is fine. I will try my luck with the minimal.iso and see

Hang on a moment, what exactly do you mean by “but mine is a file iso”? All ISOs are files when downloaded, but need to be “burnt” to a DVD or USB unless you are installing in a virtual machine.

Oh, and exacly which ISO are you using?

no, I can mount the iso file to the idrac remotely and do the installation without even going to the datacenter. I was using the AlmaLinux-8.3-x86_64-boot.iso
I am just trying the minimal.iso and it happily installs as we speak /chat

Well that’s great news. I’m still curious how you “mounted” the ISO, but if you are getting the installation done that’s all that matters.

iDRAC is an out-of-band module embedded in the server with its own network port and no software to be installed. It’s accessed with html5 (other servers, notably Oracle, use java which creates too many problems). Using the module you can mount an iso image (sort of mount -o loop image.iso /mountpoint) and boot to it to install an OS.
almalinux installed without a glitch using the minimum.iso
the repositories feel a bit slow though!

1 Like

Thanks for getting back to me. Before I retired I was handling mainly IBM/Lenovo kit and I don’t think I’ve worked on a Dell for this millennium! An interesting and rather good idea. Wiki has an article on it.

yes, I remember those days where everything had to be done locally with a KVM. Nowdays all major servers have some kind of out-of-band system embedded, called different things idrac(dell) ,iLo(hp) or TSM(lenovo) and especially now with the pandemic you only need to configure its port manually (although with dells you can use your phone with bluetooth for that) everything else you can do remotely :slight_smile:

@NG_mime and @MartinR , I thought the boot.ISO was purely intended for performing kickstart builds.

You burn the boot.ISO to disk, interrupt at GRUB make several kernel parameter changes then “tell the machine” to boot, it reaches out to the kickstart server and grabs the kickstart file (*ks.cfg) and initiates the actual provisioning and building of the machine’s OS.

That is the only reason I have ever downloaded the boot.iso file. Just for that sole purpose.

@warron.french I normally prefer to do network installations. You download the boot ISO and burn it to disk/USB. It boots and behaves just like the DVD ISO but is a LOT smaller. During the configuration you need to ensure that your network is up, and that it is pointed at the BaseOS repo. It then sets up the disks and downloads the packages required, and only those required. It even gives the effect of a dnf update without trying!

The downsides are that you probably wouldn’t want to do it over the internet if you are building several machines - better to download once. However if you run your own mirror repository that’s not an issue. It’s also no use if you’re not allowed to connect to the internet (again, unless you have your own repo).

@MartinR , yes, precisely.