Installation problem

I am trying to install almalinux on my server in RAID 1 MIRROR for it there is no problem it detects it correctly the problem is on the home page concerning the rest sources that don’t want them even if I have to put it manually it doesn’t want
I’m not sure if it’s a good idea to use the same software as the one on this image.
ps: I am French

Hi @Link_Darck It seems as though you are trying to install CentOS 8, not AlmaLinux OS?

no i’m not trying to install centos but alma linux i used the image as an example for the problem i have on almalinux

@Link_Darck are you specifically referring to the Installation Source and the error snippet you can read in the image you provided?

Did you alter the BaseOS repository, or add an extra repository by clicking on the button for [Installation Source]? Or are you referring to the configuration step for [Network and Host Name]? What specifically do you need help on first?

We need a common starting point. The image is a helpful start, but I don’t understand your question well enough.

I did not modify anything I just launch the OS I configure my network to put bond0 and I make the user and the root and it is at the time of the installation which puts the error on the image I did not modify anything of the bone that it marks this problem and impossible to install the bone until the problem of repo is not regulated

You need to tell us exactly what you are doing:

  1. What is the installation source device (USB, DVD …)?
  2. What is the installation file you downloaded (eg AlmaLinux-8.3-x86_64-boot.iso)?
  3. How did you burn/copy it?

Then we can try to suggest how to solve the installation source warning.

  1. Install USB
  2. i teste AlmaLinux-8.3-x86_64-boot.iso and AlmaLinux-8.3-x86_64-dvd.iso
  3. i use Rufus

Generally using Rufus is not a good idea. It can be made to work, but unless done exactly right can corrupt the USB. If possible use dd(1), I think there is a Windows version if you need it. Most importantly, ensure that the copy finished before removing the USB. On Linux use sync(1) and umount(8) or a eject on a GUI. On Windows ensure you use “safely remove this device” and wait.

You should use either AlmaLinux-8.3-x86_64-boot.iso or AlmaLinux-8.3-x86_64-dvd.iso, not both.

AlmaLinux-8.3-x86_64-boot.iso you need to specify the installation source as

and make sure you use the correct capitalisation.

AlmaLinux-8.3-x86_64-dvd.iso you need to specify the installation source as the local USB/DVD

In both cases do not add anything else at this stage. Once the installation can find the installation source you can deal with the other warnings, but this first step is critical.

Did you chose a specific Security Profile to apply to your machine build? I ask because that can cause some issues.

I have also seen problems with Rufus extracting an ISO to USB jumpdrive. I used another popular tool extracting the ISO on Windows partition into a USB jumpdrive; which for the life of me I cannot remember the name of presently. When I am home from work I will try to update this post again.

@Link_Darck This a an upstream problem which Red Hat is aware of. You can get this to work by using Rufus and burning in DD mode. Attached is a pic to show you what I am talking about.

Screen Shot 2021-05-03 at 23.58.31

@jack, this is very useful knowledge.

@MartinR I’m going to try your technique this weekend, hope it works

@warron.french “Have you chosen a specific security profile to apply to your machine version? I ask because it can cause problems.” What do you mean?
I would test jumpdrive USB

jack I’ve done this before and it doesn’t work

@Link_Darck I applied the “DISA STIG” and it can cause challenges, so you address them before continuing with the installation. You may even have to change Software Selections to Minimal or whatever, “Server with GUI” brings a ton of challenges, so you are better of installing with one Software Selection and then going back and performing a:

dnf groupinstall "Server with GUI"
If that is what you even want, that’s merely an example.

AlmaLinux 8.3 install

  1. I use a “custom”, “partition” to setup my system. It recognized the disks attached. I had to use the hex calcuator (between ears) figure out the sizes of partitions. Two disks are ext4 formatted with alot of data. It was hard to figure out how set up mount points. When I finally got it to work the OS that resides on a SSD gave me no information about size and available space. On a forth disk I put the .iso file for full installation. I install in a few minutes. Once installed I looked at mount points and found several to be missing. The disk that contained the .iso was erased. All other disk were erased, eventhough they were not flaged to be formatted. This flaw also exists in Mint and other Linux distributions - so we assume that it orrignated with IBM/RH. How does something that has worked for 20 years get broken and not tested.
    We currently use SL 6…5 and SL 7.6 on our systems and are looking for a replacement.

2nd install problem. At reboot the system shuts down, reboots and get hung up at step 123.?? as it is looking at a USB scanner attached to seystem. Power off / on and a forced reset boot and it worked. This is a repeatable restart problem. This is a serious issue.
The hardware is a Gigabyte 970a- rev 2 MB. an older system with no operational issues we use for test.

if this is not your topic can you go somewhere else or create your own topic instead of using mine because as far as I can see this is not a message to help me

@ljl thank you. Can you please report it on If you can please include the output from sosreport as well.

thank you my problem is solved thanks to your solution thank you very much

just like Fedor Kids - Good Bye Forever

@ljl Sorry about that. I do not think he should have done that to you. He was probably frustrated at the time. We definitely welcome everyone and I would appreciate if you would back and perhaps we can work on finding a solution for you together.

@Link_Darck Everyone here is trying to get a problem solved. I am glad that we were able to help. Please be patient and kind. If someone comes into the thread, let’s be polite and see if we can solve both problems instead of asking someone to leave.

We are all better if we work together and help each other.

1 Like