Intel S2600 motherboard os install & Graphic problem


I did make several attempt to install AlmaLinux on Intel Server motherboard S2600 including different model like the S2600CW2R.
Something is wrong with graphic card and if I do not use or some add-on graphic card or the Rmm4 KVM to make the OS setup, its impossible to get signal and see what happen on screen.

Does anyone have a solution for this problem,


Are you blacklisting the nouveau driver?

If you are temporarily remove the blacklisting of the nouveau driver to enable video to get from your system to the GPU and therefore through the cable to your monitor-device.

Also, can you switch to an alternate terminal CTRL-ALT-F3 {F4…F6} etcetera?

1 Like

Hello Warron.french,

No I did not blacklist anything, I am now busy to configure an Intel S2400SC motherboard and I have exactly the same problem.
I tried to switch from terminal CTRL-ALT-F3 change nothing.
I am able to install the OS using the KVM or addon graphic card but not with default card.

I just want to confirm that I am using text mode .

If Almalinux & Redhat 8 dont allow most of the older Intel server board to work correctly we are in deep trouble …

Any help is welcome.


I tried on Intel S5520HCR & Intel S2400SC & Intel S2600 no way to have graphic card working .

No body else have have the same issue ?


Intel pages say that the board had integrated graphics. Desktop motherboards used to have integrated graphics with separate chip until IGP started to appear in the CPU. Not so sure about server boards.

I took a peek in Fujitsu and Dell servers. Both had integrated Matrox graphics chip. Dell iDRAC corresponds to Intel RMM4?

If you do not get signal from the board to monitor, then you can’t access BIOS/EFI, can you? That is a problem that you would have with any OS. Of course, if you do have remote management, then you might have access to BIOS.

If you had enough access to select PXE boot, then you could boot the installer with kickstart (all config in ks) or with VNC support (and connect to installer over net with VNC client). Either way, there would be no need for monitor on the server.

I have installed CentOS Linux 8 on Fujitsu Primergy server dated to 2011. The graphics was no issue, but RHEL 8 has no support for the older RAID controller in that model. Luckily, ELRepo has driver disks that the installer can load over net. Otherwise the installer would not have seen any storage volumes.

Has there been any update to this issue? I am having the same problem with S2600 motherboards in white-box servers. Note that the BIOS and initial boot works on the built-in graphics; it does blank as the PXE install gets under way.


  1. Create PXE boot images from the download distribution (AlmaLinux 8.5).
  2. Set up server BIOS for PXE boot. (Yes, the BIOS is visible on the VGA output through a KVM switch.)
  3. Boot to PXE; my PXE server brings up the menus and lets me select my AlmaLinux 8.5 install.
  4. Install starts. After just a screenful of messages or two (sorry, no easy way to capture), the screen goes completely blank and the KVM says “no signal” and nothing further can be done.

Powercycling the server restores the boot menus and BIOS on the KVM.

So something happening during the install causes the graphics to shut off.
Hooking up a real display instead of a KVM results in the same thing.

No one cares.
We have contacted redhat, almalinux, oracle .

That does not work since months impossible to install AlmaLinux on Intel motherboard type S55xx S24XX S26XX.

Some problem related to graphic driver in the Kernel that was never fixed.
It was working in previous Almalinux Version.

I tested with Brand new last generation S26XX board and Xeon silver CPU same story…

Even on normal boot it is easy to observe (unless one has “rhgb quiet” options) that the mode of text changes. The kernel probably initializes “better mode” when it has loaded graphics drivers. The virtual consoles will use that mode. Later in boot a window system finally starts (if set to do so).

I did just troubleshoot a (CentOS 7) system, where the “better mode” is all black. However, it did not lose signal …

You have bootloader in PXE. The kernel command-line options are there to tweak. Alas, I have no idea which options to kernel and dracut would help the kernel do “the right choice” about video modes. The default choice is obviously not ok.

What was the last “working” kernel version?

Hello jlehtone,

It work when installing the 8.3 from ISO then when you update the system to last version and reboot it stop to work.


RHEL 8.3 had kernel 4.18.0-240
RHEL 8.4 shifted to 4.18.0-305 Chapter 4. New features Red Hat Enterprise Linux 8 | Red Hat Customer Portal
RHEL 8.4 shifted to 4.18.0-348 Chapter 6. Device Drivers Red Hat Enterprise Linux 8 | Red Hat Customer Portal
Neither list of “updated drivers” has no obvious “Intel”, but perhaps I’m looking for wrong things.

Red Hat rarely drops hardware support during lifetime of major release. The question is thus: what feature-change makes us blind?

We did already check almost all what was possible to check and we did never found why after this kernel 4.18.0-240 it was no longer working.

For me this combo works without any noticeable problems:
_Intel S5520HC mobo + 2*Xeon X5670 (whitebox build)
_AlmaLinux release 8.5 (Arctic Sphynx) + kernel 4.18.0-348.20.1.el8_5.x86_64 (updated without problems from an initially installed version of 8.3)

I also use “nomodeset” as a kernel boot parameter (declared in /etc/default/grub at the end of the “GRUB_CMDLINE_LINUX=” line) that forces a low resolution vga text mode

Hello Bodgan_ro,

Ok I never tried to use nomodeset as a kernel boot parameter.

But you for sure first need to install a working 8.3 without update then modify the Grub settings before to update the system and reboot.

Will give a try on my next install with 8.3 and the nomodeset . I need to install an Intel S2400SC next days.

Thx for the info

Hi Damocles,

You’re right, I installed a minimal 8.3 in graphic mode. But I usually do the nomodeset trick as one of the first configs after installing a server (CLI only and I’m happy), that’s why (I think…) I didn’t noticed the problem you mentioned on newer EL kernels.

I would be tempted to suggest you to directly try an 8.5 forcing a text-mode install. Yeah, the look & feel of the '90s :slight_smile:

If the install succeeds (fingers crossed !), when the machine restarts for the first time, insert nomodeset directly in the grub stage (sorry, the link is for Ubuntu, but as long as grub2 is involved the “edit” procedure is distro-independent). Once booted, add nomodeset to /etc/default/grub, update grub2 and it’s done !

Good luck !

1 Like

I did some deeper digging on the console log messages that scroll by just before the screen blanks. The screen goes blank when the kernel switches to “plymouth boot screen” mode. This happens during both the PXE install boot and a regular local boot after a successful install.

Disabling the switch to the “plymouth” mode should fix this, though how to do so during PXE is not documented. I have not yet tried the suggestions in the most recent responses.

Also see

Disable plymouth and boot much faster than before! - Robbi Nespu

though I have no idea what distro or kernel this refers to.

One more very helpful thing I found: While the physical VGA console goes blank on my S2600 systems, the BMC virtual console remains working at the higher resolution settings.
So, if you have BMC configured you can see what is going on.