Issue after updating to alma linux 9.4

HI, after update to alma linux 9.4 when i tried to boot show up some messages on screen, something about: “handler or method for GPE OD, disabling event”
Bascialy i can’t boot… what i can do?

Might be ACPI as in: Trying to understand "ACPI No handler or method for GPE" / Kernel & Hardware / Arch Linux Forums
Therefore, see what pci=nommconf as kernel cmdline option (add in GRUB) does.

another thing i noticed its if i enter manually will works its just when i turn off the pc that doesn’t boot automatically

Enter what where? The pci=nommconf ?

If yes, then it should be stored in the boot entries. Run

grubby --update-kernel=ALL --args="pci=nommconf"

and then

grep options /boot/loader/entries/*.conf

If the latter shows what we hope for, then boot should succeed “hands down”.

no, i meant that if i press shift after turning on the pc to access to the boot menu i select the alma linux 9.4 i can enter in the system, its just if i turn off the pc, obviously i’m haiving also other issue after the update but i will think to them after.
I hope now its clear

maybe i can put some screenshots also in case

if i select that one highlighted i can enter and if i check its alma linux 9.4, the other one instead i can’t because will show me that issue

In other words, if you choose the 5.14.0-362.24.2 kernel, then system boots ok,
but if you let the default – 5.14.0-427.16.1 – boot, then you get the issue.
Does the 5.14.0-427.16.1 have the issue too?


Highlight the 5.14.0-427.16.1 and press ‘e
Then you should see the boot entry and be able to append the pci=nommconf to the options line.
After edit is complete, start boot with Ctrl-x

If that skips the issue, then use the grubby to make the edit permanent.

yes correct with the default i have the issue, i’ll try that and let you know

i tried to append that but i had the same issue… i put that line below the rest

No. I has to be on the same line as the “linux” is.

For example, replace the rhgb quiet with the pci=nommconf (because the ‘rhgb’ and ‘quiet’ hide some of potentially helpful diagnostic messages).

i tried that and now sems like spamming the error instead to not booting

i think at this point i have to reinstall from scratch and see if works

are you sure its correct to replace rhgb quiet with pc=nommconf

It is safe to remove the rhgb and quiet options; I always do.

Whether the pci option helps is the question.

The existing options are easiest way to point which line to add the pci option into.

yea but how i said before after i put that didn’t solve anything in this case

Well, if you did already test correctly and the pci option made no difference, then something different is necessary. I don’t know what that is.

You can test whether 9.4 install media boots correctly. If it does, then issue is in your files. If the installer fails to boot, then issue is in the kernel.

if with the older kernel works something it’s cause when i upgrade to the new kernel

i discovered that if i reboot i can enter in the latest kernel system but only if i turn off the pc i have that issue