Log output on screen when no users are logged in

I’ve got a weird thing happening and I’m wondering if you can help me understand it. I’m running AlmaLinux 9.1 on an old laptop as my home server. The laptop’s built-in screen is broken so I use an external HDMI monitor in multi-user mode. When I’m not using the machine in person–which is 99% of the time–I turn the monitor off so that I don’t burn it out or waste energy. On the rare occasion when I need to use that machine in person, I’ll just turn the monitor back on and log in.

And this is where it gets weird: when I turn the monitor on after an extended period of time, the screen is usually filled with raw log entries, such as:

[84996.339914] Bluetooth: hci0: BCM: chip id 70
[84996.342915] Bluetooth: hci0: BCM: features 0x06
[84996.360917] Bluetooth: hci0: BCM43142A
[84996.362637] Bluetooth: hci0: BCM43142A0 (001.001.011) build 0000
[84996.366006] Bluetooth: hci0: BCM: firmware Patch file not found, tried:
[84996.367697] Bluetooth: hci0: BCM: 'brcm/BCM43142A0-105b-e065.hcd'
[84996.369370] Bluetooth: hci0: BCM: 'brcm/BCM-105b-e065.hcd'
[84997.388299] r8169 0000:03:00.0 enp3s0: Link is Up - 100Mbps/Full - flow control rx/tx
[84998.402032] Bluetooth: hci0: Opcode 0x1003 failed: -110
[84998.402037] Bluetooth: hci0: command 0x1003 tx timeout

(This is only the tail end of the screen output. There is usually much more than this showing on the screen, and it’s not limited to Bluetooth. This is the tail of what I found on-screen today.) This morning, I was able to hit “Enter” on my keyboard to access the login prompt

computer login: _

but I seem to recall that this method of getting the login prompt doesn’t always work. Sometimes I’ll have to force a new tty through Ctrl-Alt-F[1,2,3,4…].

I would like to find a way to stop the screen from filling up with log entries when no user is logged in and just have it waiting at a login prompt, but in the absence of that, I would settle for knowing why it happens and maybe even a better, more reliable way of accessing the login prompt when it does.

FWIW, I also have Arch installed on that machine, and I use it for the same purpose and in the same way. I don’t recall ever finding log entries on the screen after an extended period in Arch like I do in Alma, but I may be misremembering. In other words, this might not be a problem exclusive to Alma, but since I’m currently experiencing it in Alma, I’m asking this group.

Any ideas what’s going on?

@michael8rown I suspect that a default setting in /etc/sysctl.conf might be configured to print kernel messages to your console.

Here are two linkes to review and make adjustments accordingly for yourself:
This one shows you can manipulate the behavior and with a confirmed result

This one validates the four fields.

This one explains the numerical values of the log-levels

I hope this all helps you.

@warron.french thank you so much for your help. I believe this has solved my problem. Here are the exact steps I followed based on the links you sent:

  1. Last night, I examined /etc/sysctl.conf. This file did not contain any active directives; all contents of this file were comments.

  2. I ran sudo sysctl -a | grep kernel to see all the loaded kernel parameters. Based on your links, the value I was concerned with was kernel.printk = 7 4 1 7

  3. I added the following new line to /etc/sysctl.conf: kernel.printk = 3 4 1 3 This value was chosen based on the answer at your first link.

  4. I ran sudo sysctl --system to reload sysctl configuration.

  5. I ran sudo sysctl -a | grep kernel again and verified the value of kernel.printk, which was kernel.printk = 3 4 1 3

  6. Today, I turned on the monitor this morning, and I have checked it periodically throughout the day, and I found the prompt to be what I expect, computer login: _ with a blinking cursor. No more random log output.

So I believe this has solved my problem. Thank you again!

I am glad I could help you @michael8rown.