Mergerfs install in alma Linux 9

Hi everyone,
I have made several attempts but I have not been able to install mergerfs on alma Linux 9 server.
I installed several additional repositories, but when I do a sudo dnf search mergerfs, I find nothing.
I have searched google and found nothing about it.
I tried to download with wget or curl from github, but without success.
If anyone knows a solution, help would be appreciated.
Thanks in advance.

According to

  1. Install epel and rpmfusion repos.
    sudo dnf install --nogpgcheck$(rpm -E %rhel).noarch.rpm

    sudo dnf install --nogpgcheck$(rpm -E %rhel).noarch.rpm$(rpm -E %rhel).noarch.rpm

  2. Install rpmsphere-release (It is a manual install)
    sudo dnf install

  3. Install mergerfs. (sudo dnf install mergerfs)

Hi, thanks for the info.
I think I missed a repository.
I’ll check right away.

I had not installed rpmsphere-release.
After trying to install mergerfs, I got the following error message: nothing provides needed by mergerfs 2.32.4-1.x86_64.
adding the --skip-broken or --nobest option gave no results.
I know what is missing but I can’t find it.

I tried to compile the source rpm, but it depends on a package called ‘pandoc’ which has twenty other dependencies. The package looks like it was compiled with a newer version of glibc. Let me know if you find anything.

I found a solution, install docker and install mergerfs in this way. I still have to install other things with docker.
Thanks for your help and patience.
Anyway I’m going to try to compile mergerfs on Opensuse Leap, on my personal machine.

1 Like