Websearch hints that there has been a Xen kernel 4.9.241-37.el7.x86_64, also built by CentOS Virtualization SIG. Since that was built by “third-party”, we got an explanation for the error message.
I don’t recall ever using Xen virtualization. I think I did try to grok it, failed, and chose libvirt/KVM instead. IIRC, both the host and guest did use a Xen-version of kernel. If true, then (A) reverting to CentOS kernel in the guest would be an issue, and (B) one has to get a Xen-kernel for AlmaLinux. As said, I don’t know a thing about those.
Note: One can check with yum where did packages were installed from. For example:
yum --disablerepo=* list installed kernel\*
Thought so. However, do consider a hypothetical worst case: something fatal happens to the server – flat tire, earthquake, a terrible flood, locusts. Do you have any contingency plan for such scenarios?
It should be possible to install the regular kernel. Then you would have kernel-4.9.241-37.el7 and kernel-3.10.0-1160.119.1.el7
However, that gets us to GRUB. It loads one kernel. Install of 3.10.0 may change the default from 4.9.241 into the 3.10.0.
If the 3.10.0 cannot boot – if a Xen kernel is required – then you do need recovery.
GRUB may (or may not) be set to briefly show the installed kernels to choose from. If you cannot access that menu, then you cannot select a different (non-default) kernel.
I.e. cannot boot with 4.9.241. Unbootable system counts as “broken”?
GRUB has some means to “try entry once”, but I have no experience with that (and it has to be done in whichever way it would have been done in CentOS 7).
thanks. No, I can’t access GRUB during boot - but… I can get a full restoration of my server if it plays up. So, I guess I can install the regular kernel on a sunday morning, reboot server and it if messes up - restore it back to saturday night build again.
So, which rpm should I install and where would I download it from please?