MySQL crash dump on AlmaLinux 8.8

I have sent SIGABRT to MySQL process but I am not getting the crash dump file. Server is AlmaLinux 8.8 (4.18.0-477.21.1.el8_8.x86_64 x86_64 x86_64) and MySQL version is 8.0.32.

Set the configuration as follows and restarted to no avail:



Set the core to unlimited

$  cat /proc/`pidof -s mysqld`/limits|egrep '(Limit|core)'
Limit                     Soft Limit           Hard Limit           Units
Max core file size        unlimited            unlimited            bytes

I tried setting these values as below but it is not accepted and result in MySQL failing to boot up.


I tried setting the core dumps in systemd and restarted MySQL. Issue is still there.


It works with gcore but I want to test it when I send SIGABRT to MySQL. MySQL failed last time with SIGABRT and I want to test dump is working as expected.

It says it’s writing a core file but no core files found:

2023-11-26T21:54:46Z UTC - mysqld got signal 6 ;
Most likely, you have hit a bug, but this error can also be caused by malfunctioning hardware.
Thread pointer: 0x0
Attempting backtrace. You can use the following information to find out
where mysqld died. If you see no messages after this, something went
terribly wrong...
stack_bottom = 0 thread_stack 0x100000
/usr/libexec/mysqld(my_print_stacktrace(unsigned char const*, unsigned long)+0x41) [0x5649f366bc51]
/usr/libexec/mysqld(print_fatal_signal(int)+0x3c3) [0x5649f26b1f43]
/usr/libexec/mysqld(handle_fatal_signal+0x6d) [0x5649f26b1fbd]
/lib64/ [0x7f19d4f15cf0]
/lib64/ [0x7f19d006b251]
/usr/libexec/mysqld(Mysqld_socket_listener::listen_for_connection_event()+0x68) [0x5649f26a7918]
/usr/libexec/mysqld(mysqld_main(int, char**)+0x38e9) [0x5649f2443d39]
/lib64/ [0x7f19cff81d85]
/usr/libexec/mysqld(_start+0x2e) [0x5649f242334e]
The manual page at contains
information that should help you find out what is causing the crash.
Writing a core file