Network stop working after network "huge" load

Hi, i just installed Alma Linux recently. Is on a HP microdesk for running ngrok agent.

When i made a “stress” test for traffic (uploading on ngrok http and downloading a 6 gb file with wget) the network stop working, cant ping to local, even to but the NIC is still active. This happens after 10 o 15 minutes durning the test.

using nmtui trying activating and deactivating the NIC even the problem persist.

to get online again i need to reboot.

Im stuck on this. Please help me.

OK, interesting, but we would need some additional details i.e.:

  • which version of Alma Linux? (8.9 / 9.3 ?)
  • details of just which model (and generation) of HP “microdesk” ?
    • do you mean ProDesk, or EliteDesk etc. ?
    • CPU type, RAM installed, BIOS version ?
    • are you using the embedded NIC and/or add-in/PCI NICs ?
      • what is the NIC chipset(s) ?
  • have you been able to recreate this same issue on a separate physical machine?

Alma linux 9.3
HP HP EliteDesk 705 G3 Desktop Mini
CPU: AMD PRO A6-9500E R5
BIOS Version: P26 Ver- 02.43
Integrated NIC: NetXtreme BCM5762 Gigabit Ethernet PCIe

I have not been tried on another machine.

this screen is showed after the network “crash”

I google it and some one on a forum mention that running ethtool -K enp1s0 tso off

but still getting the same problem.

I tried with centos 7 and got the same problem

Looks rather similar to this known Broadcom tg3 driver issue

Reboot the machine, enter the grub menu, and manually add these kernel parameters temporarily, to see if this makes any difference:

amd_iommu=off intel_iommu=off

(NOTE: you might not even need the Intel one, as you’re on an AMD system)

Hope this helps. Good luck!

Thank you. I implemented changes on /etc/sysctl.conf file. but the same result :frowning:

Tried this: networking - Broadcom NetXtreme BCM5762 Gigabit Ethernet disconnects after a while - Ask Ubuntu ?

Thak you for the information. I tried but, the problem persist :frowning:

after a research i found this article IBM Documentation

i tried disabling TSO and the problem seems to be solved!.


Wow… I’ve usually only found major issues with various kinds of NIC-specific offloading on the BSD distributions, so this is good to know. Nice find, luisorozcomx !

And congratulations on finding a working solution yourself! :grinning:

I hope this help some one in the same situation.

Thank you @LinuxGuy1997 and @ankesh