No hostkey alg error from RHEL6 ssh to AlmaLinux9

When I ssh from RHEL6 to AlmaLinux9, there is a “no hostkey alg” error. Has anyone encountered this problem? How to solve it?Thanks.

probably the sha1 deprecation issue

Yes, It is the sha1 deprecation issue. It can be solved by the following methods.

$ update-crypto-policies --set DEFAULT:SHA1

“solved” is not what i’d call it, you’ve basically lowered the security posture of your alma9 box to accommodate rhel6 boxes which ideally should be replaced.