PERC H745 drivers

Did I just spend $7,000 for nothing? Bought a brand spanking new Dell PowerEdge R750xs with PERC H745 controller and it can’t see the hard drive (neither does Windows 10 just for fun). But I can’t find a driver for it anywhere. Dell web site basically says FU. Is there a secret repository somewhere?
Years ago I had an issue with an old Dell and AlmaLinux 8 but found a driver on (I think) elrepo, but coming up blank this time. Am I SOL? Should I just use it to put plants on?

Made marginal progress. Dell says to use megaraid_sas-07.721.03.00_el9.0-2.x86_64.iso from their web site. I use: inst.dd=http://XXX.XXX.XXX.XXX/megaraid_sas-07.721.03.00_el9.0-2.x86_64.iso during boot.
But later on I see:
[ 18.766725] dracut-initqueue[1601]: DD: Extracting: kmod-megaraid_sas
[ 18.876376] dracut-initqueue[1636]: modprobe: ERROR: could not insert ‘megaraid_sas’: Exec format error

Have no idea what that means. And both the iso and rpm give the same error message

Run lspci -nn to see device ID. Might look like [1028:1f3b]
If you can find that from ELRepo’s list, great: HTML Redirect

The ID in my sample above is not there, but there is kmod-megaraid_sasand
looking at one mirror of ELRepo’s DUD images Index of /linux/elrepo/dud/el9/x86_64/
I see:


It might be that the 07.719 does not yet include the desired support and one really needs the 07.721, but one can ask the ELRepo maintainers to build a new version.

The other point to note on the above are the el9_0, el9_1, and el9_2 (just like the DELL image had el9.0). The kernel in each RHEL point update does differ enough to not be compatible with kernel modules build for the other kernel versions. One has to use the appropriate version, i.e. el9_2, when installing Alma 9.2.

I bet that the “Exec format error” is due to that the DELL package is for el9.0, i.e. Alma 9.0.

Thanks, but this is during initial install. I already tried the el9_2 but it always fails with that “Exec format error”

As jlehtone noted, the Dell-supplied rpm is release version specific. I looked at the package. It installs into /lib/modules/5.14.0-70.22.1.el9_0.x86_64/extra. This means that you have to use Alma 9.0 installation disk (iso).

I thought of that… But I haven’t been able to find a download of AlmaLinux 9.0 anywhere. About to try it on RHEL 9.0 (if the download ever completes) but there’s just too much overhead with Red Hat. The elrepo 9.2 doesn’t give an error, but it still can’t find the drive.

Then the related question is: If I do get it to work on 9.0, dnf updates will then take it to 9.3. Will it still work, or crash and burn?

If elrepo’s kmod for el9_2 does not work, then you cannot update the system to 9.2. It is necessary to find out why the elrepo driver does not work.

But if you manage to install 9.0, then you can at least find the device ID as per jlehtone’s post. That info will be helpful.

One can choose “Troubleshoot” in the bootloader menu of the installer media. Then “rescue” in submenu. (Or something like that.)
Or, switch to console prompt during the normal installer run.

Won’t those allow run of lspci, even when the installer does not have support for the devices?

AlmaLinux does have a vault for old things. For example: Index of /9.0/isos/x86_64/

First: I want to thank those of you who responded. I learned a LOT from your suggestions.
Second: This has NOTHING to do with the drivers!
If you go into the Dell Lifecycle Controller utility and select “OS Deployment” and set the options for RHEL Linux, then it all magically works!

1 Like