Problem installing Nextcloud client from EPEL

I tried to install the nextcloud-client from the EPEL repository. It does not work, but I am not sure what to do with the error message. Is this just a problem with the Nextcloud package?

Try: dnf enablerepo=epel-testing nextcloud-client

I tried as well: dnf install --enablerepo=epel-testing
No luck. It’s not in there.

This seems to be a bug, but I am not really sure where to report it.

you don’t seem to have epel enabled, there also seems to be a lot of problems with qt5 from epel, i’d report it there as it won’t be almalinux-specific.

1 Like

The nextcloud-client package is in epel-testing. It had to be compiled for the new QT libraries. The version that is in the epel-testing repo is nextcloud-client-3.6.4-3.

Try again:

sudo dnf clean all
sudo dnf install enablerepo=epel-testing nextcloud-client


I had the EPEL repo enabled before.
Now I did the clean all and the other install command you suggest, but still without success:

[ralph@almalinux9 ~]$ sudo dnf install enablerepo=epel-testing nextcloud-client
[sudo] password for ralph: 
Last metadata expiration check: 0:04:53 ago on Fri 06 Jan 2023 09:04:01 CET.
No match for argument: enablerepo=epel-testing
Error: Unable to find a match: enablerepo=epel-testing

Sorry for the bad command syntax.
Correct command:

sudo dnf install --enablerepo=epel-testing nextcloud-client
1 Like

Thanks. Indeed, now it worked.
What I do not understand yet: Do I receive updates for this package now? Do they come from the testing channel? What to do to receive updates for a stable nextcloud-client package in the future?

Each package must be epel-tested first. After that it will be replaced as an update in epel.
Update in the standard way.

1 Like