Problems with AL 9

Dear friends,
is there any plan to supplement the repositories at least to Almalinux 8 level?
I was changing the computer (home server) and on that occasion switched from AlmaLinux 8 to AlmaLinux 9.
The result is disaster.
The program motion and fswebcam are nowhere to be found.
Other issues:
NFS worked for me on AL8 without any problems, on AL9 I couldn’t get it to work.
GPSD doesn’t get along with NTPD here, although there was no problem on AL8.
What happened?

Neither AlmaLinux 8 nor 9 seems to have them.
EPEL has fswebcam for AlmaLinux 8, so it is up to EPEL to build it for AlmaLinux 9.
AlmaLinux has Synergy Repository | AlmaLinux Wiki for packages that are not yet in EPEL.

Our psychic powers cannot reveal what exact errors you do have. You must tell more.

I do know “functional” AL9 NFS servers and clients, so NFS is most likely a config issue.

1 Like

I guess I don’t understand something.
I have these repositories:

[rna@nuc24 ~]$ dnf repolist
ID repozitáře:                                                     Název repozitáře:
almalinux-synergy                                                  AlmaLinux 9 - Synergy
appstream                                                          AlmaLinux 9 - AppStream
baseos                                                             AlmaLinux 9 - BaseOS
centos-nfs-ganesha-4                                               CentOS-9-stream - NFS-Ganesha 4
crb                                                                AlmaLinux 9 - CRB
elrepo                                                    Community Enterprise Linux Repository - el9
epel                                                               Extra Packages for Enterprise Linux 9 - x86_64
epel-cisco-openh264                                                Extra Packages for Enterprise Linux 9 openh264 (From Cisco) - x86_64
extras                                                             AlmaLinux 9 - Extras
rpmfusion-free-updates                                             RPM Fusion for EL 9 - Free - Updates
rpmfusion-nonfree-updates                                          RPM Fusion for EL 9 - Nonfree - Updates

and fswebcam is still not found:

[rna@nuc24 ~]$ sudo dnf search webcam
Poslední kontrola metadat: před 0:06:43, Čt 4. ledna 2024, 15:34:20.
============================================================================ Souhrn odpovídá: webcam ============================================================================
cheese.x86_64 : Application for taking pictures and movies from a webcam
cheese-libs.x86_64 : Webcam display and capture widgets
cheese-libs.i686 : Webcam display and capture widgets
kamoso.x86_64 : Application for taking pictures and videos from a webcam

Yes, as I said:

  • EPEL 8 has fswebcam
  • EPEL 9 does not have fswebcam

You have to request from EPEL that they would add fswebcam into EPEL 9.