Problems with latest update to 8.8?

So, every other morning or so, I run dnf list updates. This morning, I see the many, many files indicative that the 8.8 update has arrived. Normally, such an update is no more complicated than ‘dnf upgrade’.

But, this time, not only did a whole slew fail, but…even my normal trick of trying to install updates either one at a time is having major issues. Some work, but mostly, fail. And, whats really puzzling, if I run ‘dnf clean all’, and try again (often helps), now, no updates are showing at all.

Have I broken something, or is there actually something amiss?

Well, seems to have resolved itself. Perhaps I was trying to upgrade at a ‘bad time’ for various repos (which I’m guessing were in near thrash-mode synching various things).

Looks like Wireguard is broken on the kernel included in 8.8 as well. The wireguard module is just missing :-/

Are you using elrepo’s kmod-wireguard? If so, the version for el 8.8 is currently at the elrepo-testing repository. You can install it by running:

dnf --enablerepo=elrepo-testing update kmod-wireguard