Serious issue with RAID - only boots in Emergency state

Continuing the discussion from Almalinux 8.6 boots after normal reboot in emergency state with raid1:

Guys, I am a bit disappointed about the activity in this forum.
My post from more than 2 weeks ago has not received one single comment. Of course, the content may be badly formulated, etc, but I think it is quite specific and detailed. PLease check again:



I mentioned in the post a registered bug report about raid and emergency booting which is relevant I think, but no response. I did expect some response. I tried Rocky Linux before on the same hardware (previous motherboard, as I thought the problem could only be there - all other hardware was proved to be OK - assuming nothing could be wrong with the software…) and I got about 10 responses. I finally replaced the motherboard and had the same problem again… SO I tried AlmaLinux 8.5 and 8.6 in RAID 1. Same problem with emergency booting again.

I now continued testing again:
I did again a fresh install of Almalinux 8.6 now, not as RAID1, but a normal installation on exactly the same hardware(but of course on 2 out of the 4 disks I have)
No problems what so ever to install, reboot, restart etc. No issues at all.
So it must be an issue with the OS and RAID1.
All comments are appreciated!
Thanks for reading!

UPDATE: So the issue was indeed with the OS - not with my server.
Due to the lack of response in this forum I downloaded Rocky Linux 9, installed it on exactly the same server (!) and no issues at all, everything works as it should! So no hardware issues, but a OS issue with RAID 1.
Thanks for reading.

By “OS” you mean “8” and “9”. Yes, the 9 is different OS from the 8.

Alma and Rocky strive to be practically identical with RHEL and therefore with each other.

So, any idea why this problem happens? I also want to set up a RAID1 array when I install AlmaLinux 9, but now I’m thinking I’d better go with something else. Since there is barely any activity for this forum question, where should this be reported? I would think this would be a high priority for AlmaLinux developers.