Shiboleth with AlmaLinux 9

Has anyone tried using Shiboleth with AlmaLinux 9? The documentation doesn’t list AlmaLinux as officially supported and there’s no packages specifically for AlmaLinux. It seems likely the RockyLinux 9 packages would work, since the project doesn’t provide RHEL specific packages either even though RHEL is officially supported. Documentation says to use CentOS packages for RHEL 7 and 8 and nothing about what to use for RHEL 9, so I guess for RHEL 9 one would use the RockyLinux 9 packages.

I tried using the RockyLinux 9 packages and now have working integration of httpd with my organisation’s single sign on.

It initially didn’t work due to an issue described at

which was far from obvious. I found it by setting


in /etc/shibboleth/shibd.logger which revealed this in the shibd log

2022-11-24 16:53:47 DEBUG XMLTooling.libcurl.InputStream : msg 1, 56
from curl
2022-11-24 16:53:47 ERROR XMLTooling.ParserPool : fatal error on line 0,
column 0, message: unable to read from socket for URL

The issue was resolved by a colleague who manages the server making it return a content-length header. We use Shibboleth on CentOS 7 and the issue doesn’t exist there. So if anyone’s using Shibboleth on CentOS 7 and then tries doing same with AlmaLinux 9 and finds it doesn’t work, maybe it’s that issue.