Size display can't be changed (virtualbox)

I’m interested in using alma 9, so I’m testing the KDE-version in virtualbox 6.1.34. Host is a Manjaro 5.19.0-1 KDE. Several OS (Windows, Debian) are working fine. Alma 9 is acting quite bitchy.
If I change the size of the display (I know how to do on KDE), it goes back to 640:480.
If I try to update, it is said that there is a problem withpgp-keys and I should talk to a person of distribution. So please, if anyone can help me in English or German, that would be fine.

Are the guest additions installed?

No, they aren’t. to install Additions I need to install some apps for the kernel (sudo install kernel kernel-devel kernel-headers gcc make perl elfutils-libelf-devel tar bzip2). To install is not possible, because of trouble with bdb_ro Packages database … usind dbd_ro backend. … GPG-testing with mistake
I can’t solve this problem.
So installing Additions is impossible.

Running openbox on a FreeBSD VirtualBox, without additions for the guest. I found I was able to get it larger by adding xrandr -s 1280x1024 in the Alma’s .xinit. On said VB install, I start in text mode and run X with startx. Another option, but also probably only good with X rather than Wayland, is to add a file to /etc/X11/xorg.conf.d like

Section "Screen"
        Identifier "Screen0"
        Device     "Card0"
        Monitor    "Monitor0"
        SubSection "Display"
             Depth   24
           Modes "1920x1080"   

Again this was using X, not Wayland, and the xrandr -s option was if using startx.

Also that isn’t a typo leaving off quotes on the Depth 24 line. That 24 should not have quotes or it may cause an error. (Actually, it works without the depth line, but the first thing I saw when looking at solutions had it so I keep it.

Thank you very much, scottro, for proposing. This could be a way to solve; I did it on other OS. I was shure that it is a problem of installing software. So I tried to solve the problem of that PGP-Keys first and I got it. The command in Konsole is “sudo `rpmdb --rebuilddb” I found it on this website: after upgrade to 34 package management is not working properly · Issue #130 · WhitewaterFoundry/Fedora-Remix-for-WSL · GitHub
After that everything went smoothly, even the size of the display. The problem is solved.

Glad to hear you got it fixed. Hopefully, the solution will help others.