SSSD refusing to start after installation

I am setting up a Alma 8.9 server with mininmal installation base. I am trying to connect my server to our Samba 4 AD. I have been able to join the domain, but when running SSSD i am geting the following error in the logs.

  • [sssd] [sss_set_sssd_user_eid] (0x0080): Failed to set egid to 994: Operation not permitted

I have not been able to find other sources that can assist with this. I have tried so far setting

user = root

In the sssd.conf file. This made no difference.

I have also set the tried setting


in the sssd.service file to try and force sssd runnnig as root instead of the sssd service user just to see if that helped. That made no difference either. I am not sure what log files that might be of use here either.

After restarting the server sssd was able to start and set the egid. However this is not desirable. We should be able to run SSSD as the functional user sssd as intended.

Has someone been able to get sssd running as it’s functional user?