Support for Oracle VirtualBox Guest Additions

Does anybody know if AlmaLinux will support Oracle VirtualBox’s Guest Additions at all?

I am going to install the dependencies and Oracle VirtualBox Guest Additions to find out.

Well the install does complete but is not actually working. I am not positive but GRUB is not naturally booting off of the latest kernel upgraded today (4.18.0-240.22.1) due to a FIPS issue. I will post separately on that issue.

I install dependencies via:
dnf install gcc make perl kernel-headers kernel-devel elfutils-libelf-devel

I attempted to alter the resolution to “1920x1200” and the virtual machine froze. I waited for 5 minutes, but the system never recovered. So I executed a warm-reboot.

I rebooted again and could not log on using the GUI logon at all, I was forced to switch to an alternate terminal.

As soon as I uninstalled Oracle VBox Guest Additions the VM started performing normally in all aspects. VBox and AlmaLinux are not compatible presently.

VirtualBox installed okay on my system, but the imported virtual machine would not start; it threw up an error message saying to check the log file. The log file gave three options for a needed file, the one I needed was added via a terminal command line: “sudo yum install elfutils-libelf-devel*” (without the quotes). Once that was done installing, I restarted the machine, loaded up VirtualBox and the guest started up okay. VirtualBox DOES work okay on my system.

Forgot to mention, VirtualBox guest additions installed okay in the VirtualBox main window “File>Preferences>Extensions”, and also installed okay in the guest machine when it started up using “Devices>Insert Guest Additions CD”. The virtual machine can access the Internet and play sounds, just as on a Centos 8 host.

@waltrothfuss I also had to yum install elfutils-libelf-devel it did not work for me, but I am glad it worked out for you.

Just wondering, are you running Oracle VirtualBox directly on a Linux physical host? I am running Oracle VirtualBox on a Windows 10 Professional physical laptop.

Hi, Warron -

Yes, VirtualBox is being run on an AlmaLinux physical host that I set up for testing; it was originally a Centos 8 machine that I upgraded to AlmaLinux. VirtualBox has a Windows 7 virtual machine imported into it. Are you running AlmaLinux as a virtual machine on your Windows 10 laptop? If so, I have no idea what you might need to do; we only run Linux servers and have to use Windows 10 virtual machines on a Linux server for some software our accountant requires.



@waltrothfuss , yes my physical machine is running Windows 10 Pro. On my Windows 10 Pro, I am running Oracle VirtualBox where I am hosting a single AlmaLinux-8.3 machine.

Within this host (named alma) I attempted to install and run Oracle VirtualBox Guest Additions. It is the version appropriate for what I am running on my physical Windows 10 Pro machine.

Hi, Warron -

Did you first install the guest additions in VirtualBox itself, before trying to install it in the virtual machine? You do that in the Oracle VM VirtualBox Manager screen, that is what starts up when you run VirtualBox. Then go to FIle > Preferences > Extensions. If the Extension Pack is not listed there, it needs to be added.

You should download the Extension Pack from Oracle for the version of VirtualBox you are using. The current version is 6.1.18. On this page,, you can download the current version for your host and also the correct Extension Pack. The Extension Pack includes the Guest Additions. Once the Extension Pack is added into the VirtualBox manager, start up your virtual machine and then you can add it to the virtual machine: Devices > Insert Guest Additions CD Image … . Once you have done that, in the virtual machine’s file manager locate the Guest Additions CD image in the [virtual] CD drive, then run Setup; or, you may just see this screenshot, attached, when you Insert Guest additions CD Image; if so, just hit the Run button, and you don’t need to try to find the correct file on the CD Image to actually run the guest additions.
.Screenshot at 2021-04-19 07-22-05.png

You may have to touch the keypad’s right CTRL button in order to release the cursor and go to the top menu to hit the Devices button to insert the Guest Additions CD, or to hit the Run button.

If it turns out to be more complicated than this, then you are beyond my expertise and should consult the VirtualBox online documentation.

Best wishes,


@waltrothfuss , yes sir. I am running the latest Oracle VirtualBox v6.1.18. I have also upgraded the Extension Pack via preferences to v6.1.18 as well. Then after building my machine, alma, I attempted to install and run Oracle VBox Guest Additions v6.1.18.

Thanks for trying to help me. I have been using Oracle VBox for quite awhile, but I do not get into super complex configurations. I will see tonight if I can find any other updates for my Windows machine (not likely to me a culprit presently), for AlmaLinux or whatever else I can find.

I was swamped with other important chores last night, so I apologize for the delay in responding.

Hi, Warron -

Here is a website with some additional tips on installing a Centos 8 virtual machine:

Since AlmaLinux is essentially Centos 8, this may work for you.

This is not something I have ever had to do, as we have Linux servers and run a couple Windows virtual machines, the reverse of what you are trying to do.

Best wishes,


@waltrothfuss I think you for trying to support. I have seen that link too.

I did not find any updates that made a difference.

Hi, Warron -

The problem seems to be with VirtualBox or the Centos 8 source code rather than with AlmaLinux. I set up a Windows 10 host with VirtualBox 6.1 and tried to install both AlmaLinux and Centos 8, same results as you had with both AlmaLinux and Centos 8. Then I uninstalled VBox 6.1 and installed an older version, 5.32, and repeated the AlmaLinux and Centos 8 installations. Same results.

Then on a LinuxMint Mate machine with VirtualBox 6.1, same results with both AlmaLinux and Centos 8. See attached screenshot.

I do know that if you use either Centos 8 or AlmaLinux as the Host OS and install VirtualBox 6.2, that you can then install a client Windows 10 virtual machine without any problem.

You could try following the advice on this website (or did you already?), to first add the EPEL repository with

$ sudo dnf install epel-release

and then

$ sudo dnf install gcc make perl kernel-devel kernel-headers bzip2 dkms

This suggests that even though you install the development and system tools as part of your Centos8 or AlmaLinux install (which I did every time, they are part of the Software installation menu in the install process), that the right software packages are not installed to allow VirtualBox’s Guest Additions to build the kernel modules.

Let us know if this works!



@waltrothfuss thank you for the followup. My windows machine has to remain as Windows because sometimes I use it to VPN into work and they use a specific VPN client that I am not permitted to use another OS (politics).

So, I am gracefully going to bow out of this discussion. I wish there was a way to mark it as closed or finished or never resolved or something. That’s a feature on this forum I would love to be able to see.

Thank you again, sincerely, @waltrothfuss .

Try RPMFusion

dnf install

dnf install VirtualBox-guest-additions VirtualBox-kmodsrc

@lee , thank you.

I will try this tonight, hopefully.

Hi @warron.french

If you installed it manually, then you might have to uninstall

Below steps work in EL 8 also.

And then install via dnf.