The GUI does not appear on bootinh

My laptop is configured for dual boot. I can boot Windows 11 or by going into the boot loader (GRUB) I can change the operating system to be booted. Alma Linux is on a solid state drive. The drive worked fine on my desktop and on the laptop for many months. Although it continues to work on the desktop, it comes up in emergency mode on the laptop. My directories and files are all intact. I’ve tried a variety of tricks to no avail.

An update to the laptop from Dell or from Windows must have compromised something, but I have no idea what. Help would be appreciated! Thanks.

can you provides logs /var/log/messages.
boot with a iso almalinux in rescue mode
mount your file root
a send the /var/log/messages

Thank you for the contact. It may take me a day or two to lay hands on the log.

As a new user I’m not allowed to upload files. What is pasted below is the contents of the /var/log/messages file from January 31. I hope this is helpful. I did find two other log files. One is a boot.log. The other is obtained when I boot Alma into emergency mode. The system says to “enter journalctl -xb to view system logs.” I could provide those if you think they would be useful.

Whoops! Pasting the log file into this box generated the following error message:

Multiple errors occurred: 1) Body is limited to 32000 characters; you entered 195491. 2) Sorry, new users can only put 2 links in a post.

I had no links, so I don’t understand that part of the message. What to do?


Would it be helpful for me to send you the first 32,000 characters to avoid the limitation? Alternatively, if you would like me to send the whole file to a separate email address, just let me know.


The problem got solved. My Alma Linux is on a solid state drive which I plug into a usb port on either my desktop, where it worked, or my laptop, where the problem was. The desktop has a hard drive called Shared which I use to move files back and forth between Alma and Windows. I put a mount for it into fstab. the laptop does not have a Shared drive, so Alma choked on booting. Deleting the mnt from fstab restored the gui. Now, when I need to use Shared on the desktop, I mount it with a trivial script.

The fstab could have an entry similar to:

UUID=29..0e /mnt/Shared  xfs  defaults,noauto,nofail,x-systemd.automount,x-systemd.idle-timeout=300  0  0
  • There is no even attempt to boot the volume at boot due to noauto.
  • The x-systemd.automount,x-systemd.idle-timeout=300 makes systemd generate an automount unit on boot. That unit automatically mounts the volume if/when you try to access anything within in (in/under /mnt/Shared for the example) and umounts the volume again, if it is unused for 5 minutes (300 sec).

That is the easiest “script” for the job.