Trouble Setting Chromium Policies/Preferences

Chromium on AlmaLinux 8.4 is not following any policy or preference that I try to set. For now, I am just trying to set the homepage on configured systems to “localhost/”. These systems are being deployed remotely and end users should not have to change this setting. Using Google Chrome or another browser like Firefox is also currently not an option.

I have followed the instructions provided by chromium documentation:

And I found the below (and a few other sites I lost the links to) showing that chromium may prefer an “initial_preferences” file rather than a “master_preferences” file.

Chromium simply ignores any policy or preference that I set. It doesn’t seem to change any value at all for better or worse.

Here is an example of what I have:


   "HomepageLocation": "localhost/"

I’ve tried similar preferences as well, trying both “initial_preferences” and “master_preferences”:


   "homepage" : "localhost/"

Per the documentation, policies should immediately take effect after being put down and should override any preferences, whether system or user-specific. I’ve tried putting down these files at all variety of times during system setup - immediately after OS installation before chromium installation, after chromium installation before opening the application, after opening the application, allowing user’s preferences files to be created and putting these down + trying to modify those, etc. I’ve tried them together, separately, with just about every combination and timing that I can think of. I’ve also tried playing around with permissions on each of these files, but nothing seems to make any difference.

There has to be something that I’m missing. Any help would be appreciated.