UEFI installation with device driver disk fails to boot

I’m trying do do a UEFI-mode installation on a Dell PowerEdge R710 server with a Perc 6/i RAID controller and while the installation appears to succeed, after rebooting it stops at the grub> prompt. If I switch the server to Legacy (BIOS) boot mode the installation works perfectly but I think it ought to work in UEFI mode, too. I’m using a USB drive with the AlmaLinux 8.5 image on it and because the device driver for the Perc 6/i is megaraid_sas, I have another USB drive with that driver on it. When I boot the AlmaLinux USB drive it finds the device driver USB drive and successfully loads the megaraid_sas driver. I then choose a minimal installation which proceeds normally but after it completes and I reboot, I get this:

 Minimal BASH-like line editing is supported.  For the first word,
 TAB lists possible command completions.  Anywhere else TAB lists
 possible device or file completions.


I tried these commands at the grub> prompt and here’s what I get:

grub> ls
(proc) (hd0) (cd0)
grub> ls (hd0)
(hd0): Filesystem is unknown

I’ve booted the USB into rescue mode and looked at /boot/efi/EFI/almalinux/grub.cfg and noted that it references hd2, which is the designation of the RAID array during installation, with the Almalinux USB being hd0 and the device driver USB being hd1. I’ve tried editing grub.cfg to change hd2 to hd0 everywhere but the behavior remains unchanged.

Has anyone else tried this? Thanks in advance for any help.


Problem found and solved. It was all a matter of searching Google with the right keywords (“poweredge r710”, “uefi”, “linux”). I found this article: https://www.dell.com/community/PowerEdge-Hardware-General/Dell-PowerEdge-R710-and-RHEL-6-2-UEFI-enabled/td-p/3836482/page/2 which says, “RHEL 6.2 and the PERC 6/i RAID controller have issues booting a GPT partition over a certain size (we’re guessing 2 TB, but that’s just a guess).” I had been trying to install AlmaLinux on a single 4.5TB virtual disk. After reconfiguring so that I had a 48GB virtual disk for the OS and the rest of the space for file storage, AlmaLinux 8.5 installed and booted correctly.

Hopefully my experience will help someone else in the same situation.

1 Like