Upgrade CentOS 7 to AlmaLinux 8 with Leapp Error multiprocessing

Hi All

I’ve tried to migrate our CentOS 7 Servers with leapp as it’s described here: ELevate Quickstart Guide | AlmaLinux Wiki

When I’ve done the ‘leapp upgrade’ I got the following error:

The downloaded packages were saved in cache until the next successful transaction.
You can remove cached packages by executing ‘dnf clean packages’.
Process Process-476:
Traceback (most recent call last):
File “/usr/lib64/python2.7/multiprocessing/process.py”, line 258, in _bootstrap
File “/usr/lib64/python2.7/multiprocessing/process.py”, line 114, in run
self._target(*self._args, **self._kwargs)
File “/usr/lib/python2.7/site-packages/leapp/repository/actor_definition.py”, line 72, in _do_run
actor_instance.run(*args, **kwargs)
File “/usr/lib/python2.7/site-packages/leapp/actors/init.py”, line 290, in run
File “/usr/share/leapp-repository/repositories/system_upgrade/common/actors/dnfpackagedownload/actor.py”, line 51, in process
xfs_info=xfs_info, storage_info=storage_info, plugin_info=plugin_info, on_aws=on_aws
File “/usr/share/leapp-repository/repositories/system_upgrade/common/libraries/dnfplugin.py”, line 385, in perform_rpm_download
test=True, on_aws=on_aws
File “/usr/share/leapp-repository/repositories/system_upgrade/common/libraries/dnfplugin.py”, line 219, in _transaction
e.stdout = e.stdout.encode(‘utf-8’, ‘xmlcharrefreplace’)
AttributeError: can’t set attribute

Actor dnf_package_download unexpectedly terminated with exit code: 1 - Please check the above details

Debug output written to /var/log/leapp/leapp-upgrade.log


A report has been generated at /var/log/leapp/leapp-report.json
A report has been generated at /var/log/leapp/leapp-report.txt


Answerfile has been generated at /var/log/leapp/answerfile

Does anyone also have this issue and a solution for my problems?

Many thanks before


I ran into exactly the same issue: https://github.com/cpanel/elevate/issues/173.

You can try removing python36 packages (yum remove python36*) before you run the leapp preupgrade command. That did the trick for me.