Use of NFS detected. Upgrade can't proceed

I am following the Getting Started Guide and am in the process of migrating from CentOS7 to AlmaLinux8 but have stopped at resolving disincentives.

■ What I am having trouble with
The message about NFS is not resolved.
Originally, the /backup directory was opened as a backup directory for other servers by using an exports file so that it can be mounted on an IP in the same network.

We determined that this was the cause and tried the following, but the message error could not be resolved.
I would like to know if there is anything else I can check.

Executed ”leapp preupgrade” command.

Risk Factor: high (inhibitor)
Title: Use of NFS detected. Upgrade can’t proceed
Summary: NFS is currently not supported by the inplace upgrade.
We have found NFS usage at the following locations

Currently mounted NFS shares
Remediation: [hint] Disable NFS temporarily for the upgrade if possible.
We have found NFS usage at the following locations: Currently mounted NFS shares

■What I have tried

  1. comment out /etc/exports
    [root@testserver ~]# cat /etc/exports

  2. Stop/auto-start nfs service
    systemctl stop nfs
    systemctl disable nfs


I’ve never used ELevate, but does that mean
“there is machine out there that uses our share”
or “we do use share from some server”?

These could show something:

systemctl | grep nfs
findmnt | grep nfs

You could probably remove nfs-utils for the duration of the conversion.

PS. /24 is easier to type than / Both are allowed in exports.

Thanks for the reply.

We are sharing a specific directory on the server where we want to do the upgrade.

My understanding is that the answer is.
“there is a machine out there that uses our share”.

I also ran the command.
It seems to be reading the nfsd configuration file,

[root@test ~]# systemctl | grep nfs
proc-fs-nfsd.mount loaded active mounted NFSD configuration filesystem

[root@test ~]# findmnt | grep nfs
x mq/proc/fs/nfsd nfsd nfsd rw,relatime

The problem was still not resolved,
Does it seem that the only way to stop the reading itself is to delete the nfsd once?

I don’t want to do that if possible.

The proc-fs-nfsd.mount is started (the mount made), when required by a service.
The grep -r proc-fs-nfsd /usr/lib/systemd/system shows that two services, nfs-server and nfs-mountd, do require nfsd mounted.

Your output does not directly show either of those services being loaded. Both

systemctl status nfs-server
systemctl status nfs-mountd

should show “Active: inactive (dead)”

If services have been disabled and machine has rebooted since, then nothing should start the proc-fs-nfsd.mount … unless … what do you get with:

systemctl status proc-fs-nfsd.mount

One has to learn what the system has before actually making any changes.

you don’t want an nfs server to have any clients attached during an upgrade. you’re going to have to accept downtime.

you’ll probably need to disable rpcbind, nfs-server (nfs is just the client iirc), nfs-lock and all sorts of helpers.

1 Like


Once again, disabling nfs-server,
I also rebooted the physical server just to be sure.
NFS is no longer recognized and I was able to successfully upgrade.

Maybe it is not just a reboot.
I think it may have been necessary to reboot the physical server as well as the reboot.

Thanks to all of you for your advice in resolving the problem.
Best regards.