Well I tried (thrice!)

First time I ended up with a server i can’t login to on the console and ssh isn’t even running!

Also, before I even got that far i had to add edd=off to the kernel params in grub to get around Probing EDD (edd=off to disable) so might be worth doing that by default.

I didn’t get an ELevate-Upgrade-Initramfs grub entry.

I didn’t have to sudo rmmod pata_acpi

why do we need to enable root ssh - especially as all the commands are using sudo?

i ran sudo leapp answer --section remove_pam_pkcs11_module_check.confirm=True

why did all of these module streams get enabled - i am running apache on this, but not mariadb and don’t really want any python2 stuff on there, virt is for the guest tools (this is a kvm vm) i assume?:

Enabling module streams:
 httpd                                          2.4                                                                       
 mariadb                                        10.3                                                                      
 python27                                       2.7                                                                       
 python36                                       3.6                                                                       
 virt                                           rhel                                                                      

powertools, extras, ha… all sorts of repo’s enabled!

possibly needs instructions about how to change SELinux back to enforcing from permissive after the relabelling.

2nd attempt - this time i edited grub.cfg to add edd=off (noticed there is an ELupdate entry, i guess last time it got removed when i had to reboot to add that) but now i’m just stuck at a blinking cursor… yup, rebooted and now its gone and i have the same problem - logging into the console just returns me to the login prompt and ssh isn’t running.

3rd try is running now, i edited /etc/default/grub before doing the upgrade this time and am doing centos-to-centos, but assume its some PAM issue.

no, same problem, blinking cursor (also grub changes were ignored, had to add edd=off during first boot - which you mustn’t miss!)

Hi @sej7278 , I have a couple of suggestions for you, based on what I am reading and interpreting from your input/monolog here.

  1. You can set SELINUX back to enforcing after you get logged into the console (which I know you are indicating is not working; that’s my next note; do the following:
    a. after a reboot, execute:
setenforce 1; reboot

b. Or, edit the file /etc/selinux/config and alter the variable SELINUX and set to enforcing. Then,

  1. If by console, you mean the graphical logon then you need to run the following command at a terminal prompt as root or with sudo, execute:
systemctl set-default graphical.target

I apologize if I am not interpreting your statements above.

thanks for the reply, for #1 i meant maybe the wiki needed those instructions added.

for #2 i can’t login at all and its headless so no use trying a graphical target :wink:

i’ve given up for now, was just interested in helping testing, but after 3 identical failures (and no way to login to debug!) i’m just calling it non-working.

Just to be sure: “it” means ELevate?

yup. elevate simply doesn’t work for me in a simple use case - a centos 7.9 qemu-kvm vm running pretty much nothing (apache and splunkforwarder) doesn’t boot due to missing the edd=off kernel flag and even with that manually added i cannot login - i assume pam is broken as ssh doesn’t even start and the console login is stuck in a loop.

it could also be partially due to qemu-kvm, but given that’s probably where most centos7 boxes are going to be running…

i may try a very basic centos 7.9 install with a fresh kvm setup and no services running and see if that’s any different.

4th try from a fresh very basic centos 7.9 install worked!

This time i didn’t get the edd=off warning - probably due to newer qemu machine type, i got some dracut syslog /dev/log logger warning flash up and after about 5mins of just a blinking cursor i got a login prompt which worked and ssh started up!

so i’ll try to upgrade another vm now, as it only working on a fresh install is a bit pointless.

edit: just had a thought - SELinux was not enabled this time…

worked 5th time with selinux enforcing from a fresh install running nothing.

when you do the final reboot you get a blinking cursor for about 4mins, then you get a warning dracut no 'dev/log' or 'logger' included for syslog logging then a couple of minutes later it reboots (twice i think) and ssh/console works.

so not sure what the problem was before - a mixture of old libvirt flags (something to watch out for if you’re running from an older VM) and maybe some changes i made to the OS.

i’ll look into upgrading a vm i have running oracle 11g later, that’s equally as old as the splunk/apache vm.

edit: oracle11g vm upgraded fine (no edd=off and SELinux was enforcing) but for some reason this vm displays output during the ELevate reboot, and explains why it takes so long and reboots a couple of times - look at that package list!:

also wow oracle is running!

Awesome feedback @sej7278. Thanks so much and glad you finally got it to work. Please file the bugs you see so that we can improve. We knew there would be issues no doubt, but everything can be worked on.

just tried another box and whilst i get the edd=off warning still (and selinux was enforcing) the upgrade did complete